summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston-ready_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-07 11:43:59 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-20 21:10:07 +0000
commit60873f9da578054e029208ad64da14d2ceeccbbc (patch)
treeb6c22fe968012acd0db8915e70630c0b092d98f5 /meta-agl-profile-graphical/recipes-graphics/wayland/weston-ready_1.0.bb
parent38c1a71fc36256a886d7d496d4c9cffd629a8f6b (diff)
weston: add weston-ready
Weston seems to take variable amounts of time to initialize on startup depending on configuration (e.g. gst-record feature being enabled for cluster support). To avoid windowmanager and its dependencies failing, patch LayerManagerControl so that errors can be detected; then use it in a new script, weston-ready, to detect if Weston is functional. A corresponding systemd service unit is also added so that things can use it in their dependencies. Change-Id: I5711e7f9d9a891e1c7a160b5d65711bd6e7fee03 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston-ready_1.0.bb')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston-ready_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-ready_1.0.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-ready_1.0.bb
new file mode 100644
index 000000000..a3d0bb248
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-ready_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Weston readiness checker"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit systemd
+
+SRC_URI = "file://weston-ready \
+ file://weston-ready.service \
+"
+
+do_install() {
+ install -D -m 0755 ${WORKDIR}/weston-ready ${D}${bindir}/weston-ready
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -D -m 0644 ${WORKDIR}/weston-ready.service ${D}${systemd_system_unitdir}/weston-ready.service
+ fi
+}
+
+SYSTEMD_SERVICE_${PN} = "weston-ready.service"
+
+RDEPENDS_${PN} += "weston bash"