summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0004-layout-interface-added-interface-to-change-surface-id.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
commitdf4ed283e18f3dfe9f42f0012b12cb0af57bcdbb (patch)
tree40ad4b148e24c47d319bbbd23bbfc4af75a36e94 /meta-agl-profile-graphical/recipes-graphics/wayland/weston/0004-layout-interface-added-interface-to-change-surface-id.patch
parentd40e55dbb362c455f0ee863b23c21ac2628cf3f8 (diff)
parent47aa65ba73e1b29459171de24fb0ee0040cbb39c (diff)
Merge remote-tracking branch 'agl/next'
* agl/next: meta-agl-bsp: Add CONFIG_LSM workaround for 5.1+ kernels meta-agl-profile-cluster-qt5: disable qtbase patches zeus updates for dragonboard-410c meta-security: activates dbus-cynagora recipes-graphics/wayland/weston: Expose weston_output_damage() meta-agl-profile-core: tweak udisks2 configuration for AGL meta-agl-bsp/meta-arago: update weston bbappend [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Split ADSP path for ulcb and ulcb-kf Fix nss-localuser post install meta-agl-bsp: meta-raspberrypi: handle zeus upgrade meta-agl-profile-core: add patch for systemd-udevd SECLABEL crash meta-security: disable dbus-cynara patches meta-agl-bsp: handle ptest-runner upgrade meta-agl-distro: Add inc file for next branch over-rides meta-agl-distro: BBMASK problematic upstream meta-security bbappend meta-agl-distro: prefer linux-yocto 4.19 LTS kernel meta-agl-profile-graphical-qt5: enable qt5location services meta-agl-profile-core: update most recipe meta-agl-profile-core: update neardal recipe Update base local.conf.sample meta-agl-profile-graphical: don't always build agl-compositor meta-agl-profile-graphical: update weston and weston-init meta-agl-profile-graphical: update wayland-ivi-extension for weston 7.0.0 meta-agl-distro: add polkit to DISTRO_FEATURES meta-agl-profile-core: update fontconfig bbappend meta-agl-profile-core: switch to udisks2 meta-security: handle systemd upgrade meta-agl-profile-graphical-qt5: handle qtwayland upgrade meta-agl-profile-core: handle freetype upgrade meta-agl-bsp meta-agl-profile-core: upgrade to opencv 4.x meta-agl-profile-core: update rtl-sdr recipe for zeus meta-security meta-app-framework: handle xmlsec1 upgrade meta-agl-profile-graphical: upgrade to gstreamer 1.16 meta-agl-profile-core: remove libmicrohttpd backport meta-agl-profile-core: remove backported curl and nghttp2 recipes meta-agl-profile-core: remove libnfc recipe meta-agl-profile-core: remove connman backport meta-agl-profile-graphical: remove weston 5.0.0 patches meta-agl-profile-core: remove old glibc patch meta-agl-bsp/meta-intel: remove linux-firmware_git.bbappend meta-agl-bsp: remove weston and wayland-protocols backports meta-app-framework: remove libzip recipe meta-security: remove keyutils recipe Declare layer compatibility with zeus Change-Id: Ie8ee1e37958279e7cf2d503c54ffacb46ba0c31c
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston/0004-layout-interface-added-interface-to-change-surface-id.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0004-layout-interface-added-interface-to-change-surface-id.patch73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0004-layout-interface-added-interface-to-change-surface-id.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0004-layout-interface-added-interface-to-change-surface-id.patch
deleted file mode 100644
index 6401c5b81..000000000
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0004-layout-interface-added-interface-to-change-surface-id.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-index e1e897ed..5b1f12f0 100644
---- a/ivi-shell/ivi-layout-export.h
-+++ b/ivi-shell/ivi-layout-export.h
-@@ -320,6 +320,12 @@ struct ivi_layout_interface {
- struct ivi_layout_surface *ivisurf,
- uint32_t duration);
-
-+ /**
-+ * \brief set id of ivi_layout_surface
-+ */
-+ int32_t (*surface_set_id)(struct ivi_layout_surface *ivisurf,
-+ uint32_t id_surface);
-+
- /**
- * layer controller interface
- */
-diff --git a/ivi-shell/ivi-layout.c b/ivi-shell/ivi-layout.c
-index 298e18ea..fa8e75f6 100644
---- a/ivi-shell/ivi-layout.c
-+++ b/ivi-shell/ivi-layout.c
-@@ -1901,6 +1901,44 @@ ivi_layout_surface_set_transition_duration(struct ivi_layout_surface *ivisurf,
- return 0;
- }
-
-+/*
-+ * This interface enables e.g. an id agent to set the id of an ivi-layout
-+ * surface, that has been created by a desktop application. This can only be
-+ * done once as long as the initial surface id equals IVI_INVALID_ID. Afterwards
-+ * two events are emitted, namely surface_created and surface_configured.
-+ */
-+static int32_t
-+ivi_layout_surface_set_id(struct ivi_layout_surface *ivisurf,
-+ uint32_t id_surface)
-+{
-+ struct ivi_layout *layout = get_instance();
-+ struct ivi_layout_surface *search_ivisurf = NULL;
-+
-+ if (!ivisurf) {
-+ weston_log("%s: invalid argument\n", __func__);
-+ return IVI_FAILED;
-+ }
-+
-+ if (ivisurf->id_surface != IVI_INVALID_ID) {
-+ weston_log("surface id can only be set once\n");
-+ return IVI_FAILED;
-+ }
-+
-+ search_ivisurf = get_surface(&layout->surface_list, id_surface);
-+ if (search_ivisurf) {
-+ weston_log("id_surface(%d) is already created\n", id_surface);
-+ return IVI_FAILED;
-+ }
-+
-+ ivisurf->id_surface = id_surface;
-+
-+ wl_signal_emit(&layout->surface_notification.created, ivisurf);
-+ wl_signal_emit(&layout->surface_notification.configure_changed,
-+ ivisurf);
-+
-+ return IVI_SUCCEEDED;
-+}
-+
- static int32_t
- ivi_layout_surface_set_transition(struct ivi_layout_surface *ivisurf,
- enum ivi_layout_transition_type type,
-@@ -2058,6 +2096,7 @@ static struct ivi_layout_interface ivi_layout_interface = {
- .surface_get_weston_surface = ivi_layout_surface_get_weston_surface,
- .surface_set_transition = ivi_layout_surface_set_transition,
- .surface_set_transition_duration = ivi_layout_surface_set_transition_duration,
-+ .surface_set_id = ivi_layout_surface_set_id,
-
- /**
- * layer controller interfaces