summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-add-memfd-create-option.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:32:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:32:33 +0200
commitb16f1f6b8bdd7b0cef4aad3a6714798b66d8b0a5 (patch)
tree61c5df69bed7810e988b06434e8efc7ab9071acd /meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-add-memfd-create-option.patch
parent40213738bcd84fc542cda3ec6336b0e394b28dcc (diff)
parentc24cdffea9dfa3904fc3ea9da0bc80e5515b078d (diff)
Merge branch 'next'
* next: Temporary workarounds for h3ulcb and bbe [RCAR] use omx-user-module as libomxil provider meta-agl-bsp: dra7xx-evm/beaglebone updates for dunfell meta-agl-bsp: remove obsolete linux-fslc-imx bbappend meta-agl-profile-graphical-qt5: remove Chromium specific bits from SDK meta-agl-profile-graphical: disable memfd usage in weston meta-agl-bsp: update raspberrypi configuration for dunfell meta-agl-{bsp,distro}: update kernel configuration for dunfell meta-agl-profile-core: update psplash for dunfell meta-agl-profile-core: update systemd for dunfell meta-app-framework: set DISTRO_FEATURES_NATIVE meta-agl-profile-core: update bluez5 for dunfell meta-agl-profile-graphical: update weston for dunfell meta-agl-profile-graphical: update wayland-ivi-extension for dunfell meta-agl-profile-graphical: update wayland for dunfell meta-agl-profile-core: update pulseaudio for dunfell meta-security: update to audit 2.8.5 Update distro_features_check usage meta-agl-bsp: remove vboxguestdrivers recipe Declare layer compatibility for dunfell Change-Id: I879ad3040ed6f2fca3f21d189ccce7f1614013b5 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-add-memfd-create-option.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-add-memfd-create-option.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-add-memfd-create-option.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-add-memfd-create-option.patch
new file mode 100644
index 000000000..f4ea60130
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-add-memfd-create-option.patch
@@ -0,0 +1,48 @@
+Add memfd-create option
+
+Add a meson build option, memfd-create, that controls whether the
+memfd_create system call support will be enabled. The default value
+is true so that it will be enabled, but it allows users like AGL
+that currently has issues with security labels and memfd to disable
+it.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/meson.build b/meson.build
+index 82107e1..9d042ca 100644
+--- a/meson.build
++++ b/meson.build
+@@ -78,8 +78,12 @@ elif cc.has_header_symbol('sys/mkdev.h', 'major')
+ endif
+
+ optional_libc_funcs = [
+- 'mkostemp', 'strchrnul', 'initgroups', 'posix_fallocate', 'memfd_create'
++ 'mkostemp', 'strchrnul', 'initgroups', 'posix_fallocate'
+ ]
++if get_option('memfd-create')
++ optional_libc_funcs += [ 'memfd_create' ]
++endif
++
+ foreach func : optional_libc_funcs
+ if cc.has_function(func)
+ config_h.set('HAVE_' + func.to_upper(), 1)
+diff --git a/meson_options.txt b/meson_options.txt
+index 80a2ad7..4a93472 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -99,6 +99,13 @@ option(
+ description: 'systemd service plugin: state notify, watchdog, socket activation'
+ )
+
++option(
++ 'memfd-create',
++ type: 'boolean',
++ value: true,
++ description: 'Use memfd_create system call'
++)
++
+ option(
+ 'remoting',
+ type: 'boolean',