summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-ivi-layout-introcuded-configure_desktop_changed.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
commitdf4ed283e18f3dfe9f42f0012b12cb0af57bcdbb (patch)
tree40ad4b148e24c47d319bbbd23bbfc4af75a36e94 /meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-ivi-layout-introcuded-configure_desktop_changed.patch
parentd40e55dbb362c455f0ee863b23c21ac2628cf3f8 (diff)
parent47aa65ba73e1b29459171de24fb0ee0040cbb39c (diff)
Merge remote-tracking branch 'agl/next'
* agl/next: meta-agl-bsp: Add CONFIG_LSM workaround for 5.1+ kernels meta-agl-profile-cluster-qt5: disable qtbase patches zeus updates for dragonboard-410c meta-security: activates dbus-cynagora recipes-graphics/wayland/weston: Expose weston_output_damage() meta-agl-profile-core: tweak udisks2 configuration for AGL meta-agl-bsp/meta-arago: update weston bbappend [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Split ADSP path for ulcb and ulcb-kf Fix nss-localuser post install meta-agl-bsp: meta-raspberrypi: handle zeus upgrade meta-agl-profile-core: add patch for systemd-udevd SECLABEL crash meta-security: disable dbus-cynara patches meta-agl-bsp: handle ptest-runner upgrade meta-agl-distro: Add inc file for next branch over-rides meta-agl-distro: BBMASK problematic upstream meta-security bbappend meta-agl-distro: prefer linux-yocto 4.19 LTS kernel meta-agl-profile-graphical-qt5: enable qt5location services meta-agl-profile-core: update most recipe meta-agl-profile-core: update neardal recipe Update base local.conf.sample meta-agl-profile-graphical: don't always build agl-compositor meta-agl-profile-graphical: update weston and weston-init meta-agl-profile-graphical: update wayland-ivi-extension for weston 7.0.0 meta-agl-distro: add polkit to DISTRO_FEATURES meta-agl-profile-core: update fontconfig bbappend meta-agl-profile-core: switch to udisks2 meta-security: handle systemd upgrade meta-agl-profile-graphical-qt5: handle qtwayland upgrade meta-agl-profile-core: handle freetype upgrade meta-agl-bsp meta-agl-profile-core: upgrade to opencv 4.x meta-agl-profile-core: update rtl-sdr recipe for zeus meta-security meta-app-framework: handle xmlsec1 upgrade meta-agl-profile-graphical: upgrade to gstreamer 1.16 meta-agl-profile-core: remove libmicrohttpd backport meta-agl-profile-core: remove backported curl and nghttp2 recipes meta-agl-profile-core: remove libnfc recipe meta-agl-profile-core: remove connman backport meta-agl-profile-graphical: remove weston 5.0.0 patches meta-agl-profile-core: remove old glibc patch meta-agl-bsp/meta-intel: remove linux-firmware_git.bbappend meta-agl-bsp: remove weston and wayland-protocols backports meta-app-framework: remove libzip recipe meta-security: remove keyutils recipe Declare layer compatibility with zeus Change-Id: Ie8ee1e37958279e7cf2d503c54ffacb46ba0c31c
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-ivi-layout-introcuded-configure_desktop_changed.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-ivi-layout-introcuded-configure_desktop_changed.patch74
1 files changed, 0 insertions, 74 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-ivi-layout-introcuded-configure_desktop_changed.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-ivi-layout-introcuded-configure_desktop_changed.patch
deleted file mode 100644
index ddd949e35..000000000
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0005-ivi-layout-introcuded-configure_desktop_changed.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-index 5b1f12f0..dd0997aa 100644
---- a/ivi-shell/ivi-layout-export.h
-+++ b/ivi-shell/ivi-layout-export.h
-@@ -187,6 +187,16 @@ struct ivi_layout_interface {
- */
- int32_t (*add_listener_configure_surface)(struct wl_listener *listener);
-
-+ /**
-+ * \brief add a listener for notification when desktop_surface is configured
-+ *
-+ * When an desktop_surface is configured, a signal is emitted
-+ * to the listening controller plugins.
-+ * The pointer of the configured desktop_surface is sent as the void *data argument
-+ * to the wl_listener::notify callback function of the listener.
-+ */
-+ int32_t (*add_listener_configure_desktop_surface)(struct wl_listener *listener);
-+
- /**
- * \brief Get all ivi_surfaces which are currently registered and managed
- * by the services
-diff --git a/ivi-shell/ivi-layout-private.h b/ivi-shell/ivi-layout-private.h
-index 2b8bd472..fe5be01a 100644
---- a/ivi-shell/ivi-layout-private.h
-+++ b/ivi-shell/ivi-layout-private.h
-@@ -104,6 +104,7 @@ struct ivi_layout {
- struct wl_signal created;
- struct wl_signal removed;
- struct wl_signal configure_changed;
-+ struct wl_signal configure_desktop_changed;
- } surface_notification;
-
- struct weston_layer layout_layer;
-diff --git a/ivi-shell/ivi-layout.c b/ivi-shell/ivi-layout.c
-index fa8e75f6..690af742 100644
---- a/ivi-shell/ivi-layout.c
-+++ b/ivi-shell/ivi-layout.c
-@@ -1040,6 +1040,21 @@ ivi_layout_add_listener_configure_surface(struct wl_listener *listener)
- return IVI_SUCCEEDED;
- }
-
-+static int32_t
-+ivi_layout_add_listener_configure_desktop_surface(struct wl_listener *listener)
-+{
-+ struct ivi_layout *layout = get_instance();
-+
-+ if (!listener) {
-+ weston_log("ivi_layout_add_listener_configure_desktop_surface: invalid argument\n");
-+ return IVI_FAILED;
-+ }
-+
-+ wl_signal_add(&layout->surface_notification.configure_desktop_changed, listener);
-+
-+ return IVI_SUCCEEDED;
-+}
-+
- uint32_t
- ivi_layout_get_id_of_surface(struct ivi_layout_surface *ivisurf)
- {
-@@ -2057,6 +2072,7 @@ ivi_layout_init_with_compositor(struct weston_compositor *ec)
- wl_signal_init(&layout->surface_notification.created);
- wl_signal_init(&layout->surface_notification.removed);
- wl_signal_init(&layout->surface_notification.configure_changed);
-+ wl_signal_init(&layout->surface_notification.configure_desktop_changed);
-
- /* Add layout_layer at the last of weston_compositor.layer_list */
- weston_layer_init(&layout->layout_layer, ec);
-@@ -2081,6 +2097,7 @@ static struct ivi_layout_interface ivi_layout_interface = {
- .add_listener_create_surface = ivi_layout_add_listener_create_surface,
- .add_listener_remove_surface = ivi_layout_add_listener_remove_surface,
- .add_listener_configure_surface = ivi_layout_add_listener_configure_surface,
-+ .add_listener_configure_desktop_surface = ivi_layout_add_listener_configure_desktop_surface,
- .get_surface = shell_get_ivi_layout_surface,
- .get_surfaces = ivi_layout_get_surfaces,
- .get_id_of_surface = ivi_layout_get_id_of_surface,