summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0012-hmi-controller-register-for-desktop_surface_configured.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-02-21 16:37:55 +0100
commitdf4ed283e18f3dfe9f42f0012b12cb0af57bcdbb (patch)
tree40ad4b148e24c47d319bbbd23bbfc4af75a36e94 /meta-agl-profile-graphical/recipes-graphics/wayland/weston/0012-hmi-controller-register-for-desktop_surface_configured.patch
parentd40e55dbb362c455f0ee863b23c21ac2628cf3f8 (diff)
parent47aa65ba73e1b29459171de24fb0ee0040cbb39c (diff)
Merge remote-tracking branch 'agl/next'
* agl/next: meta-agl-bsp: Add CONFIG_LSM workaround for 5.1+ kernels meta-agl-profile-cluster-qt5: disable qtbase patches zeus updates for dragonboard-410c meta-security: activates dbus-cynagora recipes-graphics/wayland/weston: Expose weston_output_damage() meta-agl-profile-core: tweak udisks2 configuration for AGL meta-agl-bsp/meta-arago: update weston bbappend [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Update rcar driver weston 7 bsp 3.21.0 [RCAR] Split ADSP path for ulcb and ulcb-kf Fix nss-localuser post install meta-agl-bsp: meta-raspberrypi: handle zeus upgrade meta-agl-profile-core: add patch for systemd-udevd SECLABEL crash meta-security: disable dbus-cynara patches meta-agl-bsp: handle ptest-runner upgrade meta-agl-distro: Add inc file for next branch over-rides meta-agl-distro: BBMASK problematic upstream meta-security bbappend meta-agl-distro: prefer linux-yocto 4.19 LTS kernel meta-agl-profile-graphical-qt5: enable qt5location services meta-agl-profile-core: update most recipe meta-agl-profile-core: update neardal recipe Update base local.conf.sample meta-agl-profile-graphical: don't always build agl-compositor meta-agl-profile-graphical: update weston and weston-init meta-agl-profile-graphical: update wayland-ivi-extension for weston 7.0.0 meta-agl-distro: add polkit to DISTRO_FEATURES meta-agl-profile-core: update fontconfig bbappend meta-agl-profile-core: switch to udisks2 meta-security: handle systemd upgrade meta-agl-profile-graphical-qt5: handle qtwayland upgrade meta-agl-profile-core: handle freetype upgrade meta-agl-bsp meta-agl-profile-core: upgrade to opencv 4.x meta-agl-profile-core: update rtl-sdr recipe for zeus meta-security meta-app-framework: handle xmlsec1 upgrade meta-agl-profile-graphical: upgrade to gstreamer 1.16 meta-agl-profile-core: remove libmicrohttpd backport meta-agl-profile-core: remove backported curl and nghttp2 recipes meta-agl-profile-core: remove libnfc recipe meta-agl-profile-core: remove connman backport meta-agl-profile-graphical: remove weston 5.0.0 patches meta-agl-profile-core: remove old glibc patch meta-agl-bsp/meta-intel: remove linux-firmware_git.bbappend meta-agl-bsp: remove weston and wayland-protocols backports meta-app-framework: remove libzip recipe meta-security: remove keyutils recipe Declare layer compatibility with zeus Change-Id: Ie8ee1e37958279e7cf2d503c54ffacb46ba0c31c
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/weston/0012-hmi-controller-register-for-desktop_surface_configured.patch')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0012-hmi-controller-register-for-desktop_surface_configured.patch133
1 files changed, 0 insertions, 133 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0012-hmi-controller-register-for-desktop_surface_configured.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0012-hmi-controller-register-for-desktop_surface_configured.patch
deleted file mode 100644
index 447cff4f8..000000000
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0012-hmi-controller-register-for-desktop_surface_configured.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-diff --git a/ivi-shell/hmi-controller.c b/ivi-shell/hmi-controller.c
-index a0e49ba0..340d1915 100644
---- a/ivi-shell/hmi-controller.c
-+++ b/ivi-shell/hmi-controller.c
-@@ -129,9 +129,9 @@ struct hmi_controller {
- struct weston_compositor *compositor;
- struct wl_listener destroy_listener;
-
-- struct wl_listener surface_created;
- struct wl_listener surface_removed;
- struct wl_listener surface_configured;
-+ struct wl_listener desktop_surface_configured;
-
- struct wl_client *user_interface;
- struct ui_setting ui_setting;
-@@ -576,28 +576,6 @@ create_layer(struct weston_output *output,
- /**
- * Internal set notification
- */
--static void
--set_notification_create_surface(struct wl_listener *listener, void *data)
--{
-- struct hmi_controller *hmi_ctrl =
-- wl_container_of(listener, hmi_ctrl,
-- surface_created);
-- struct ivi_layout_surface *ivisurf = data;
-- struct hmi_controller_layer *layer_link =
-- wl_container_of(hmi_ctrl->application_layer_list.prev,
-- layer_link,
-- link);
-- struct ivi_layout_layer *application_layer = layer_link->ivilayer;
-- int32_t ret = 0;
--
-- /* skip ui widgets */
-- if (is_surf_in_ui_widget(hmi_ctrl, ivisurf))
-- return;
--
-- ret = hmi_ctrl->interface->layer_add_surface(application_layer, ivisurf);
-- assert(!ret);
--}
--
- static void
- set_notification_remove_surface(struct wl_listener *listener, void *data)
- {
-@@ -665,6 +643,42 @@ set_notification_configure_surface(struct wl_listener *listener, void *data)
- switch_mode(hmi_ctrl, hmi_ctrl->layout_mode);
- }
-
-+static void
-+set_notification_configure_desktop_surface(struct wl_listener *listener, void *data)
-+{
-+ struct hmi_controller *hmi_ctrl =
-+ wl_container_of(listener, hmi_ctrl,
-+ desktop_surface_configured);
-+ struct ivi_layout_surface *ivisurf = data;
-+ struct hmi_controller_layer *layer_link =
-+ wl_container_of(hmi_ctrl->application_layer_list.prev,
-+ layer_link,
-+ link);
-+ struct ivi_layout_layer *application_layer = layer_link->ivilayer;
-+ struct weston_surface *surface;
-+ int32_t ret = 0;
-+
-+ /* skip ui widgets */
-+ if (is_surf_in_ui_widget(hmi_ctrl, ivisurf))
-+ return;
-+
-+ ret = hmi_ctrl->interface->layer_add_surface(application_layer, ivisurf);
-+ assert(!ret);
-+
-+ /*
-+ * if application changes size of wl_buffer. The source rectangle shall be
-+ * fit to the size.
-+ */
-+ surface = hmi_ctrl->interface->surface_get_weston_surface(ivisurf);
-+ if (surface) {
-+ hmi_ctrl->interface->surface_set_source_rectangle(ivisurf, 0,
-+ 0, surface->width, surface->height);
-+ }
-+
-+ hmi_ctrl->interface->commit_changes();
-+ switch_mode(hmi_ctrl, hmi_ctrl->layout_mode);
-+}
-+
- /**
- * A hmi_controller used 4 ivi_layers to manage ivi_surfaces. The IDs of
- * corresponding ivi_layer are defined in weston.ini. Default scene graph
-@@ -868,6 +882,9 @@ hmi_controller_create(struct weston_compositor *ec)
- hmi_ctrl->surface_configured.notify = set_notification_configure_surface;
- hmi_ctrl->interface->add_listener_configure_surface(&hmi_ctrl->surface_configured);
-
-+ hmi_ctrl->desktop_surface_configured.notify = set_notification_configure_desktop_surface;
-+ hmi_ctrl->interface->add_listener_configure_desktop_surface(&hmi_ctrl->desktop_surface_configured);
-+
- hmi_ctrl->destroy_listener.notify = hmi_controller_destroy;
- wl_signal_add(&hmi_ctrl->compositor->destroy_signal,
- &hmi_ctrl->destroy_listener);
-@@ -1289,12 +1306,6 @@ ivi_hmi_controller_UI_ready(struct wl_client *client,
-
- ivi_hmi_controller_add_launchers(hmi_ctrl, 256);
-
-- /* Add surface_created listener after the initialization of launchers.
-- * Otherwise, surfaces of the launchers will be added to application
-- * layer too.*/
-- hmi_ctrl->surface_created.notify = set_notification_create_surface;
-- hmi_ctrl->interface->add_listener_create_surface(&hmi_ctrl->surface_created);
--
- hmi_ctrl->is_initialized = 1;
- }
-
-diff --git a/ivi-shell/ivi-layout.c b/ivi-shell/ivi-layout.c
-index b06bf309..ef354d49 100644
---- a/ivi-shell/ivi-layout.c
-+++ b/ivi-shell/ivi-layout.c
-@@ -715,9 +715,15 @@ commit_surface_list(struct ivi_layout *layout)
- ivisurf->pending.prop.transition_type = IVI_LAYOUT_TRANSITION_NONE;
-
- if (configured && !is_surface_transition(ivisurf)) {
-- shell_surface_send_configure(ivisurf->surface,
-- ivisurf->prop.dest_width,
-- ivisurf->prop.dest_height);
-+ if (ivisurf->weston_desktop_surface) {
-+ weston_desktop_surface_set_size(ivisurf->weston_desktop_surface,
-+ ivisurf->prop.dest_width,
-+ ivisurf->prop.dest_height);
-+ } else {
-+ shell_surface_send_configure(ivisurf->surface,
-+ ivisurf->prop.dest_width,
-+ ivisurf->prop.dest_height);
-+ }
- }
- } else {
- configured = 0;