summaryrefslogtreecommitdiffstats
path: root/meta-agl-security
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-12-05 10:11:26 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-05 12:40:52 +0000
commit37e0eaae014fc3f6f498606833d56bbe7db687b0 (patch)
tree8c0324bfc69198f0dfc79bae20c0cfdb25f2dbbc /meta-agl-security
parenta67d0a0dc3187f7901e42bc8390e68547f0583d1 (diff)
Merge meta-agl-security into meta-agl
meta-agl-security only contains one recipe for xmlsec so it's not necessary to maintain a full layer for this Change-Id: I66b3eeaa0e777fcc0c94bdf562b7188b01641d86 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-agl-security')
-rw-r--r--meta-agl-security/conf/layer.conf24
-rw-r--r--meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb40
2 files changed, 0 insertions, 64 deletions
diff --git a/meta-agl-security/conf/layer.conf b/meta-agl-security/conf/layer.conf
deleted file mode 100644
index 86d435c9d..000000000
--- a/meta-agl-security/conf/layer.conf
+++ /dev/null
@@ -1,24 +0,0 @@
-####################################################
-#
-# This layer, named "meta-agl-security", is intended to host
-# receipes specific to the security framework of AGL.
-#
-# In the case where a choice exist between several security
-# framework, the switch is done using DISTRO_FEATURES in
-# configuration files.
-#
-# This layer will either hold the several framework and their
-# specific common components.
-#
-####################################################
-
-# We have a conf and classes directory, add to BBPATH
-BBPATH =. "${LAYERDIR}:"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "agl-security"
-BBFILE_PATTERN_agl-security = "^${LAYERDIR}/"
-BBFILE_PRIORITY_agl-security = "9"
diff --git a/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb b/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb
deleted file mode 100644
index 7faf7bfd4..000000000
--- a/meta-agl-security/recipes-core/xmlsec1/xmlsec1_1.2.20.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-inherit autotools pkgconfig
-
-SUMMARY = "Library providing support for "XML Signature" and "XML Encryption" standards"
-DESCRIPTION = "XML Security Library is a C library based on LibXML2 and OpenSSL. \
-The library was created with a goal to support major XML security \
-standards "XML Digital Signature" and "XML Encryption". \
-"
-
-HOMEPAGE = "https://www.aleksey.com/xmlsec"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://Copyright;md5=32e47e213c77c55d2c666351d7ce16b5"
-
-SRC_URI = "git://git.gnome.org/xmlsec;branch=master;protocol=git"
-SRCREV = "84c8281cf927b1cdcc38f343f61c3aa448a5a10f"
-
-SECTION = "base"
-
-S = "${WORKDIR}/git"
-
-RDEPENDS_${PN} = "openssl libxml2"
-
-# choice is made to use openssl only and to not use xslt
-# nss would be a valuable choice
-EXTRA_OECONF = "\
- --disable-crypto-dl \
- --disable-apps-crypto-dl \
- --enable-shared \
- --disable-static \
- --without-gnutls \
- --without-gcrypt \
- --without-nss \
- --without-libxslt \
-"
-
-do_install_append() {
- # discarding this optional file is good for AGL
- rm ${D}${libdir}/xmlsec1Conf.sh
-}
-
-
ht .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
/*
 * Copyright (C) 2016, 2017 "IoT.bzh"
 * Author: José Bollo <jose.bollo@iot.bzh>
 *
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *   http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
 */

#pragma once

/*
 * Enum for Session/Token/Assurance middleware.
 */
enum afb_session_flags_v1
{
       AFB_SESSION_NONE_V1 = 0,   /* nothing required */
       AFB_SESSION_CREATE_V1 = 1, /* Obsolete */
       AFB_SESSION_CLOSE_V1 = 2,  /* After token authentification, closes the session at end */
       AFB_SESSION_RENEW_V1 = 4,  /* After token authentification, refreshes the token at end */
       AFB_SESSION_CHECK_V1 = 8,  /* Requires token authentification */

       AFB_SESSION_LOA_GE_V1 = 16, /* check that the LOA is greater or equal to the given value */
       AFB_SESSION_LOA_LE_V1 = 32, /* check that the LOA is lesser or equal to the given value */
       AFB_SESSION_LOA_EQ_V1 = 48, /* check that the LOA is equal to the given value */

       AFB_SESSION_LOA_SHIFT_V1 = 6, /* shift for LOA */
       AFB_SESSION_LOA_MASK_V1 = 7,  /* mask for LOA */

       AFB_SESSION_LOA_0_V1 = 0,   /* value for LOA of 0 */
       AFB_SESSION_LOA_1_V1 = 64,  /* value for LOA of 1 */
       AFB_SESSION_LOA_2_V1 = 128, /* value for LOA of 2 */
       AFB_SESSION_LOA_3_V1 = 192, /* value for LOA of 3 */
       AFB_SESSION_LOA_4_V1 = 256, /* value for LOA of 4 */

       AFB_SESSION_LOA_LE_0_V1 = AFB_SESSION_LOA_LE_V1 | AFB_SESSION_LOA_0_V1, /* check LOA <= 0 */
       AFB_SESSION_LOA_LE_1_V1 = AFB_SESSION_LOA_LE_V1 | AFB_SESSION_LOA_1_V1, /* check LOA <= 1 */
       AFB_SESSION_LOA_LE_2_V1 = AFB_SESSION_LOA_LE_V1 | AFB_SESSION_LOA_2_V1, /* check LOA <= 2 */
       AFB_SESSION_LOA_LE_3_V1 = AFB_SESSION_LOA_LE_V1 | AFB_SESSION_LOA_3_V1, /* check LOA <= 3 */

       AFB_SESSION_LOA_EQ_0_V1 = AFB_SESSION_LOA_EQ_V1 | AFB_SESSION_LOA_0_V1, /* check LOA == 0 */
       AFB_SESSION_LOA_EQ_1_V1 = AFB_SESSION_LOA_EQ_V1 | AFB_SESSION_LOA_1_V1, /* check LOA == 1 */
       AFB_SESSION_LOA_EQ_2_V1 = AFB_SESSION_LOA_EQ_V1 | AFB_SESSION_LOA_2_V1, /* check LOA == 2 */
       AFB_SESSION_LOA_EQ_3_V1 = AFB_SESSION_LOA_EQ_V1 | AFB_SESSION_LOA_3_V1, /* check LOA == 3 */

       AFB_SESSION_LOA_GE_0_V1 = AFB_SESSION_LOA_GE_V1 | AFB_SESSION_LOA_0_V1, /* check LOA >= 0 */
       AFB_SESSION_LOA_GE_1_V1 = AFB_SESSION_LOA_GE_V1 | AFB_SESSION_LOA_1_V1, /* check LOA >= 1 */
       AFB_SESSION_LOA_GE_2_V1 = AFB_SESSION_LOA_GE_V1 | AFB_SESSION_LOA_2_V1, /* check LOA >= 2 */
       AFB_SESSION_LOA_GE_3_V1 = AFB_SESSION_LOA_GE_V1 | AFB_SESSION_LOA_3_V1  /* check LOA >= 3 */
};