summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-10-16 20:27:32 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-18 13:04:36 +0000
commit193349f450db0b78e6a987d9c979945c48e2a542 (patch)
tree1f7aeac620e51e6d9e68ee321ccf477287d0f77e /meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
parent321a41a7cae61d074e686cc9966f6774a3f45b9e (diff)
weston-ini-conf: Fix task signatures, mark as machine-specific package
We need to do two things here. First, bitbake does not know to track values that are found and used via getVarFlags() without them being otherwise refernced and tracked in ways that are otherwise caught. Further given that we use multiple levels of varflags here we need to be explicit in their tracking. Add all variables that we use to varflags where they are added to the metadata. This change comes directly from master. The second thing is that we need to tell bitbake/OpenEmbedded that this is a machine-specific package not architecture-generic. Bug-AGL: SPEC-965 Change-Id: I748dbf40f37aaf7f4a6dd6ddd65257fdfcf83098 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11355 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/weston-ini-conf.bb')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
index 986a9eda9..918257d88 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
S = "${WORKDIR}"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
require weston-ini-conf/screen.inc
DEFAULT_SCREEN[transform]?="270"
@@ -50,6 +52,7 @@ python do_generate_weston_init() {
#ar_src = d.getVarFlag('ARCHIVER_MODE', 'src', True)
addtask do_generate_weston_init after do_compile before do_install
+do_generate_weston_init[vardeps] = "DEFAULT_SCREEN WESTONCORE WESTONSHELL WESTONOUTPUT1 WESTONSECTION"
do_install_append() {
WESTON_INI_CONFIG=${sysconfdir}/xdg/weston