summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/weston/make-lcms-explicitly-configurable.patch
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-03-14 09:03:31 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-03-14 14:48:56 +0000
commit67662f237904ad175fc1137204356225e0507d9e (patch)
treedc43d0651175dd15a7f3a389fb112c0d690b2d7d /meta-agl/recipes-graphics/wayland/weston/make-lcms-explicitly-configurable.patch
parent20dfa8d262d6de0c689cce0d8fc0b76a40ba5a75 (diff)
Upgrade to Wayland/Weston 1.9.0
Yocto 2.0 ("Jethro") provides Wayland and Weston 1.8.0; manually upgrading to 1.9.0 does not break compatibility with existing frameworks (Qt..), while at the same time allowing easier integration of mandatory components such as Weston IVI-Shell and Wayland IVI Extension. We can thus in the same pass remove backport patches for these 2 components. Here is the related discussion on the mailing list : http://lists.linuxfoundation.org/pipermail/ automotive-discussions/2016-March/001623.html Change-Id: I874eac50ff64d8b93e32910b6f1297002faa06a5 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/weston/make-lcms-explicitly-configurable.patch')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/make-lcms-explicitly-configurable.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston/make-lcms-explicitly-configurable.patch b/meta-agl/recipes-graphics/wayland/weston/make-lcms-explicitly-configurable.patch
new file mode 100644
index 000000000..35e6d6ff5
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston/make-lcms-explicitly-configurable.patch
@@ -0,0 +1,43 @@
+weston-1.5.0/configure.ac: make lcms explicitly configurable
+
+The lcms package is outside of openembedded-core, so make it
+explicitly configurable. Make it deterministic, so that if lcms
+dependencies are missing, autoconf throws a fatal error. Follow
+upstream style to make it more likely to be merged.
+
+Upstream-Status: Pending
+
+Index: weston-1.5.0/configure.ac
+===================================================================
+--- weston-1.5.0.orig/configure.ac
++++ weston-1.5.0/configure.ac
+@@ -491,12 +491,24 @@ AC_ARG_ENABLE(demo-clients-install,
+ enable_demo_clients_install=no)
+ AM_CONDITIONAL(INSTALL_DEMO_CLIENTS, [test "x$enable_demo_clients_install" = "xyes"])
+
+-PKG_CHECK_MODULES(LCMS, lcms2,
+- [have_lcms=yes], [have_lcms=no])
+-if test "x$have_lcms" = xyes; then
+- AC_DEFINE(HAVE_LCMS, 1, [Have lcms support])
++AC_ARG_ENABLE(lcms,
++ AS_HELP_STRING([--disable-lcms],
++ [Disable lcms support]),,
++ enable_lcms=auto)
++AM_CONDITIONAL(HAVE_LCMS, [test "x$enable_lcms" = xyes])
++if test "x$enable_lcms" != "xno"; then
++ PKG_CHECK_MODULES(LCMS,
++ lcms2,
++ [have_lcms=yes],
++ [have_lcms=no])
++ if test "x$have_lcms" = "xno" -a "x$enable_lcms" = "xyes"; then
++ AC_MSG_ERROR([lcms support explicitly requested, but lcms couldn't be found])
++ fi
++ if test "x$have_lcms" = "xyes"; then
++ enable_lcms=yes
++ AC_DEFINE(HAVE_LCMS, 1, [Have lcms support])
++ fi
+ fi
+-AM_CONDITIONAL(HAVE_LCMS, [test "x$have_lcms" = xyes])
+
+ AC_PATH_PROG([wayland_scanner], [wayland-scanner])
+ if test x$wayland_scanner = x; then