summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-01-13 18:36:55 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-01-18 22:28:01 +0000
commit59fb43fa95a212af20009247332b4c5c34302b1f (patch)
tree056f68cd25c2feedd4dbce5b251a82acf5a70fec /meta-agl/recipes-graphics/wayland/weston_%.bbappend
parent91f7784cfd26ca7d26e1006d78c067e74c7dc92a (diff)
Migrate IVI-Shell backport to Weston 1.8.0 (Yocto 2.0)
(NOTICE : this is the last patch necessary to fully migrate to Yocto 2.0) As newer Poky "Jethro" is now providing Weston 1.8.0, adapt IVI-Shell 1.9.0 backport to it. Remove unnecessary patches (touchscreen support for Qt, panel toggle) which are now upstreamed. Make the systemd service recipe name more generic. Change-Id: Icaad3f40b29617bcb33ac235bbe3c65f7f4bdbd7 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..2ee7150e5
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,26 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston.service \
+ file://weston.ini \
+ "
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "weston.service"
+
+do_install_append() {
+ # Install systemd unit files
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+ fi
+
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ "