summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-04-12 14:07:33 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-19 11:18:50 +0000
commit029de35a172da31b083b86d93a79d787773dec11 (patch)
treed49ead563efec4f599900dd4abfca4c4dd14476a /meta-agl/recipes-graphics/wayland/weston_%.bbappend
parent473b4354758ea6657fd196c30fb14332b5e7178d (diff)
Use weston-init to startup weston
* weston.service should not be a part of weston recipes * remove weston.service from AGL weston recipes * yocto upstream uses the recipe weston-init to startup weston * customize weston-start with sed - remove openvt - add option to weston-launch * customize weston.service with sed - add option for weston * unified the weston startup beteween AGL BSPs * remove fix on the AGL BSP Bug-AGL: SPEC-452 Bug-AGL: SPEC-310 Change-Id: I12722826abdc004214d289961e900c36528ec6e3 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend12
1 files changed, 0 insertions, 12 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
index 217c4fc0b..dc984c1d1 100644
--- a/meta-agl/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -2,17 +2,5 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0001-compositor-drm.c-Launch-without-input-devices.patch \
- file://weston.service \
"
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "weston.service"
-
-do_install_append() {
- # Install systemd unit files
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
- fi
-}