aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-05-04 12:35:03 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-05-06 21:46:42 +0000
commit084ab213bd37fb22b4f2bd2e23859b719778c4cc (patch)
tree415eae01352aee9f1fbcc57ecd254543233fbbdc /meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
parent6f6eaaf6ab72f73a7bb9e568eb4f13b0f05fd95a (diff)
rvi-sota-client_git: add RVI SOTA client
Build and deploy sota_client and a systemd service. The application is written in the Rust programming language and depends on Cargo therefore the recipe requires on meta-rust. It is using crate dbus-rs version 0.1.2 with fixed casts of c_char raw pointers for ARM. Bug-AGL: SPEC-176 Change-Id: Ic8f24ae3dd2e62297e303be23a40759b0b919b86 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb')
-rw-r--r--meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
new file mode 100644
index 000000000..38c645ae4
--- /dev/null
+++ b/meta-agl/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "SOTA Reference Implementation project - Client"
+HOMEPAGE = "https://github.com/advancedtelematic/rvi_sota_client"
+LICENSE = "MPL-2.0"
+
+inherit cargo systemd
+
+SRC_URI = "git://github.com/advancedtelematic/rvi_sota_client.git;protocol=https \
+ file://rvi-sota-client.service \
+ "
+SRCREV="825be11b03f89c52e5441b3d26e1cbf63fd313dd"
+LIC_FILES_CHKSUM="file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += "dbus"
+RDEPENDS_${PN} += "dbus-lib libcrypto libssl bash"
+
+SYSTEMD_SERVICE_${PN} = "rvi-sota-client.service"
+
+do_install_append() {
+ install -m 0755 -p -D ${S}/client.toml ${D}/var/sota/client.toml
+ install -m 0755 -p -D ${S}/docker/run.sh ${D}${bindir}/run.sh
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -p -D ${WORKDIR}/rvi-sota-client.service ${D}${systemd_unitdir}/system/rvi-sota-client.service
+ fi
+}
+
+## dbus-rs
+SRC_URI += "\
+ git://github.com/diwic/dbus-rs.git;protocol=https;name=dbus-rs;destsuffix=dbus-rs \
+ file://dbus-rs/0001-Cast-correctly-c_char-raw-pointers-for-ARM.patch;patchdir=../dbus-rs \
+"
+
+# 0.1.2
+SRCREV_dbus-rs = "c2c4c98adcf9949992ac5b0050bf17afe10868c9"
+
+SRCREV_FORMAT .= "_dbus-rs"
+EXTRA_OECARGO_PATHS += "${WORKDIR}/dbus-rs"