summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-01-31 16:08:03 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-01-31 16:12:05 +0100
commit352bca8be39cf61c6dea758a76178ef577532f08 (patch)
tree0780dd9561fe1589982e1d3c05d5192b130fd2c4 /meta-agl
parent31d543cbcd0fa5aad0ee7dfdbd60033183d8daef (diff)
Fix crosssdk image creation
* Task do_populate_sdk and do_rootfs can't be exec simultaneously. * Both exec "createrepo" on the same directory, and so one of them * can failed (randomly). Change-Id: I106423fd9e10e95bd63503ca39921521cd5253f6 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-ivi/images/agl-image-ivi-crosssdk.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl/recipes-ivi/images/agl-image-ivi-crosssdk.bb b/meta-agl/recipes-ivi/images/agl-image-ivi-crosssdk.bb
index 104462019..9a1695b3d 100644
--- a/meta-agl/recipes-ivi/images/agl-image-ivi-crosssdk.bb
+++ b/meta-agl/recipes-ivi/images/agl-image-ivi-crosssdk.bb
@@ -10,3 +10,8 @@ IMAGE_FEATURES += "dev-pkgs"
IMAGE_INSTALL += "kernel-dev"
inherit populate_sdk
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs