summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-02-28 11:59:58 +0100
committerronan Le Martret <ronan@iot.bzh>2017-03-19 19:55:22 +0000
commit5fba83e080ddaeed451b2520b7119551700fb4fe (patch)
tree90d37364d551a6b76bd5513c3321211de79209b6 /meta-agl
parent244061f39fa541f3f50e5dcdaa6e3949ab4c549b (diff)
Remove useless fix weston
* this fix is already present in weston 1.11.0 * the patch "0001-compositor-drm.c-Launch-without-input-devices.patch" need to be updated to be compliant to weston 1.11.0 Bug-AGL: SPEC-411 Change-Id: Ife5be1fe06578a55296f0aa1d668d5a1edcba475 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch18
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/fix-touchscreen-crash.patch29
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend1
3 files changed, 9 insertions, 39 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
index 0d7b9ee61..93b7739fd 100644
--- a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
+++ b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
@@ -1,10 +1,11 @@
-From d46538cde290f2638d3631a8789f659b433c2d2a Mon Sep 17 00:00:00 2001
+From 43f66e20a6788388df4fc052d257f005c359080f Mon Sep 17 00:00:00 2001
From: Leon Anavi <leon.anavi@konsulko.com>
-Date: Mon, 24 Oct 2016 14:54:02 +0300
+Date: Wed, 14 Dec 2016 12:26:31 +0200
Subject: [PATCH] compositor-drm.c: Launch without input devices
-Launch Weston 1.9 even if input devices (such as
-a keyboard or a mouse) are not present.
+Launch Weston 11 even if input devices (such as
+a keyboard, a mouse or a touchscreen) are not
+present.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
@@ -12,17 +13,16 @@ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
1 file changed, 1 deletion(-)
diff --git a/src/compositor-drm.c b/src/compositor-drm.c
-index 6777bf8..ab493ad 100644
+index fd89627..f66e0af 100644
--- a/src/compositor-drm.c
+++ b/src/compositor-drm.c
-@@ -3149,7 +3149,6 @@ drm_backend_create(struct weston_compositor *compositor,
+@@ -3123,7 +3123,6 @@ drm_backend_create(struct weston_compositor *compositor,
if (udev_input_init(&b->input,
- compositor, b->udev, param->seat_id) < 0) {
+ compositor, b->udev, seat_id) < 0) {
weston_log("failed to create input devices\n");
- goto err_sprite;
}
- if (create_outputs(b, param->connector, drm_device) < 0) {
+ if (create_outputs(b, config->connector, drm_device) < 0) {
--
2.7.4
-
diff --git a/meta-agl/recipes-graphics/wayland/weston/fix-touchscreen-crash.patch b/meta-agl/recipes-graphics/wayland/weston/fix-touchscreen-crash.patch
deleted file mode 100644
index 71b41accf..000000000
--- a/meta-agl/recipes-graphics/wayland/weston/fix-touchscreen-crash.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Fix Weston crash on touchscreen input
-
-Check for touch->focus before using it, as some touchscreens will generate
-out-of-screen coordinates and cause touch->focus to be NULL. (e.g. Raspberry Pi
-display, some displays after weston-calibrator)
-
-Bug-AGL: SPEC-309
-
-Upstream-Status: Backport [https://cgit.freedesktop.org/wayland/weston/commit/src/input.c?id=2c40d1d30eabe46706822a8b5c94579aeba58e84]
-===================================================
---- a/src/input.c 2015-09-14 14:23:28.000000000 -0400
-+++ b/src/input.c 2016-11-09 16:06:28.371959318 -0500
-@@ -245,11 +245,14 @@
- struct wl_list *resource_list;
- wl_fixed_t sx, sy;
-
-+ if (!touch->focus)
-+ return;
-+
- weston_view_from_global_fixed(touch->focus, x, y, &sx, &sy);
-
- resource_list = &touch->focus_resource_list;
-
-- if (!wl_list_empty(resource_list) && touch->focus) {
-+ if (!wl_list_empty(resource_list)) {
- serial = wl_display_next_serial(display);
- wl_resource_for_each(resource, resource_list)
- wl_touch_send_down(resource, serial, time,
-
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
index 573b481a9..95b886c6e 100644
--- a/meta-agl/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -4,7 +4,6 @@ SRC_URI_append = "\
file://0001-compositor-drm.c-Launch-without-input-devices.patch \
file://weston.service \
file://weston.ini \
- file://fix-touchscreen-crash.patch \
"
inherit systemd