summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-13 15:24:58 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-16 12:25:26 +0000
commit5fcfb16981111c09493b59e4f1b521bba1b505b3 (patch)
tree4eadeff2298b71b040db8426a0c6c9c62b097cab /meta-agl
parent736ed0252f96cbbadfb787b56ae0258c7a923644 (diff)
replace deprecated function base_contains
* replace base_contains by bb.utils.contains * base_contains is deprecated use bb.utils.contains instead * yocto version: 2.2 Change-Id: Iaed1e8d0dd36d7ad348ac144fdcdf28ccd359e40 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-core/psplash/psplash_git.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-agl/recipes-core/psplash/psplash_git.bbappend b/meta-agl/recipes-core/psplash/psplash_git.bbappend
index 3b4f85102..c2c58c562 100644
--- a/meta-agl/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl/recipes-core/psplash/psplash_git.bbappend
@@ -9,8 +9,8 @@ SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
inherit systemd
-SYSTEMD_PACKAGES = "${@base_contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
-SYSTEMD_SERVICE_${PN} = "${@base_contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
+SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
+SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
do_configure_append () {
cd ${S}
@@ -18,7 +18,7 @@ do_configure_append () {
}
do_install_append () {
- if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
fi