summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-05-31 07:11:31 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-02 00:57:36 +0000
commit0ea9f9fd830ec1e9a5bc776cac7a9cab7c452a24 (patch)
tree19453d2e0e0ff7f3c71fda908f5aaf7e07570ac2 /meta-agl
parent5a63eef23be9adb662a4dac8f13f7d64fd4ef673 (diff)
agl-login-manager,agl-desktop-config: Move layer to meta-agl
agl-ivi-image is using agl-login-manager and agl-desktop-config. However, those aren't included in meta-agl layer. So agl-ivi-image isn't built only with meta-agl layer. Bug-AGL: SPEC-625 Change-Id: Ied4bbec9c72d2f7cac5b01c2465fe395c2e5497c Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9587 Reviewed-by: Martin Kelly <mkelly@xevo.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb47
-rw-r--r--meta-agl/recipes-config/agl-login-manager/files/agl-user-session.pamd3
-rw-r--r--meta-agl/recipes-config/agl-login-manager/files/agl-user-session@.service18
-rw-r--r--meta-agl/recipes-config/agl-login-manager/files/user-config.path8
-rw-r--r--meta-agl/recipes-config/agl-login-manager/files/user-config.service8
-rw-r--r--meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb21
-rw-r--r--meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path8
-rw-r--r--meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service12
8 files changed, 125 insertions, 0 deletions
diff --git a/meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb b/meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
new file mode 100644
index 000000000..c86838268
--- /dev/null
+++ b/meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
@@ -0,0 +1,47 @@
+SUMMARY = "AGL Login manager"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit agl-graphical
+
+SRC_URI += " \
+ file://user-config.service \
+ file://user-config.path \
+ file://agl-user-session.pamd \
+ file://agl-user-session@.service \
+"
+
+LOGIN_USER ??="agl-driver agl-passenger"
+
+do_install_append() {
+
+ install -d ${D}${sysconfdir}/pam.d/
+ install -m 0644 ${WORKDIR}/agl-user-session.pamd ${D}${sysconfdir}/pam.d/agl-user-session
+
+ install -d ${D}${systemd_user_unitdir}
+ install -d ${D}${systemd_user_unitdir}/default.target.wants
+ install -m 0644 ${WORKDIR}/user-config.service ${D}${systemd_user_unitdir}
+ install -m 0644 ${WORKDIR}/user-config.path ${D}${systemd_user_unitdir}
+
+ sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
+ -i ${D}${systemd_user_unitdir}/user-config.service
+ sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
+ -i ${D}${systemd_user_unitdir}/user-config.path
+
+ ln -sf ${systemd_user_unitdir}/user-config.path ${D}${systemd_user_unitdir}/default.target.wants
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -d ${D}${systemd_unitdir}/system/multi-user.target.wants/
+ install -m 0644 ${WORKDIR}/agl-user-session@.service ${D}${systemd_unitdir}/system/
+
+ for AGL_USER in ${LOGIN_USER};do
+ ln -sf ${systemd_system_unitdir}/agl-user-session@.service ${D}${systemd_unitdir}/system/multi-user.target.wants/agl-user-session@${AGL_USER}.service;
+ done
+}
+
+FILES_${PN} += "${sysconfdir}/pam.d/agl-user-session"
+FILES_${PN} += "${systemd_user_unitdir}/*"
+FILES_${PN} += "${libdir}/systemd/user/default.target.wants/*"
+FILES_${PN} += "${systemd_unitdir}/system/agl-user-session@.service"
+FILES_${PN} += "${systemd_unitdir}/system/multi-user.target.wants/*"
diff --git a/meta-agl/recipes-config/agl-login-manager/files/agl-user-session.pamd b/meta-agl/recipes-config/agl-login-manager/files/agl-user-session.pamd
new file mode 100644
index 000000000..462c3648b
--- /dev/null
+++ b/meta-agl/recipes-config/agl-login-manager/files/agl-user-session.pamd
@@ -0,0 +1,3 @@
+account include common-account
+session required pam_loginuid.so
+session include common-session
diff --git a/meta-agl/recipes-config/agl-login-manager/files/agl-user-session@.service b/meta-agl/recipes-config/agl-login-manager/files/agl-user-session@.service
new file mode 100644
index 000000000..b128a40c8
--- /dev/null
+++ b/meta-agl/recipes-config/agl-login-manager/files/agl-user-session@.service
@@ -0,0 +1,18 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=User Manager for UID %i
+After=systemd-user-sessions.service
+
+[Service]
+User=%i
+PAMName=agl-user-session
+ExecStart=-/bin/sleep 2147483648
+KillMode=mixed
+Delegate=yes
+TasksMax=infinity
diff --git a/meta-agl/recipes-config/agl-login-manager/files/user-config.path b/meta-agl/recipes-config/agl-login-manager/files/user-config.path
new file mode 100644
index 000000000..07f61f646
--- /dev/null
+++ b/meta-agl/recipes-config/agl-login-manager/files/user-config.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=AGL user config unit path
+
+[Path]
+PathExists=@DISPLAY_XDG_RUNTIME_DIR@/wayland-0
+
+[Install]
+WantedBy=default.target
diff --git a/meta-agl/recipes-config/agl-login-manager/files/user-config.service b/meta-agl/recipes-config/agl-login-manager/files/user-config.service
new file mode 100644
index 000000000..0bf37fb4b
--- /dev/null
+++ b/meta-agl/recipes-config/agl-login-manager/files/user-config.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=AGL user config
+
+[Service]
+ExecStart=/bin/ln -sf @DISPLAY_XDG_RUNTIME_DIR@/wayland-0 %t/
+
+[Install]
+WantedBy=default.target
diff --git a/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb b/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb
new file mode 100644
index 000000000..e0358d615
--- /dev/null
+++ b/meta-agl/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "AGL desktop config"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += " \
+ file://user-weston-term.service \
+ file://user-weston-term.path \
+"
+
+do_install_append() {
+ install -d ${D}${systemd_user_unitdir}
+ install -m 0644 ${WORKDIR}/user-weston-term.service ${D}${systemd_user_unitdir}
+ install -m 0644 ${WORKDIR}/user-weston-term.path ${D}${systemd_user_unitdir}
+
+ install -d ${D}${systemd_user_unitdir}/default.target.wants
+ ln -sf ${systemd_user_unitdir}/user-weston-term.path ${D}${libdir}/systemd/user/default.target.wants
+}
+
+FILES_${PN} += "${systemd_user_unitdir}/*"
+FILES_${PN} += "${systemd_user_unitdir}/default.target.wants/default.target.wants"
diff --git a/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path
new file mode 100644
index 000000000..9481840e5
--- /dev/null
+++ b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.path
@@ -0,0 +1,8 @@
+[Unit]
+Description=Terminal for weston user unit path
+
+[Path]
+PathExists=%t/wayland-0
+
+[Install]
+WantedBy=default.target
diff --git a/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service
new file mode 100644
index 000000000..ad8b9583b
--- /dev/null
+++ b/meta-agl/recipes-graphics/agl-desktop-config/files/user-weston-term.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Terminal for weston user
+After=user-config.service
+Requires=user-config.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/weston-terminal
+Restart=always
+
+[Install]
+WantedBy=multi-user.target