summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-05-20 11:12:55 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-05-22 11:29:23 +0000
commit43aaed60e34d4ce621eb914638e794849a50aa40 (patch)
treee5d6cb74a60f025e942b21cc2fa67aa6b3c7b1be /meta-agl
parent4bb0f58514164cbd0d997403c8149c07851490fb (diff)
run-agl-postinsts: run before systemd-user-sessions
Add setting of Before to the template scheme in the run-agl-postinsts recipe, and use it to make sure run-agl-postinsts runs before systemd-user-sessions. This ensures that on first boot all of the applications will be installed before HomeScreen is started in the user session. Bug-AGL: SPEC-580 Change-Id: I08026f225971e1fe38e984dfed5fc2656955942c Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9439 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service1
-rw-r--r--meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb3
2 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service b/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
index a80b16002..61d6d4679 100644
--- a/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
+++ b/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
@@ -2,6 +2,7 @@
Description=Run pending agl postinsts
DefaultDependencies=no
After=#SYSTEMD_SERVICE_AFTER#
+Before=#SYSTEMD_SERVICE_BEFORE#
ConditionPathExists=#SYSCONFDIR#/agl-postinsts
[Service]
diff --git a/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb b/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
index 5b5e18a99..96c171fa8 100644
--- a/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
+++ b/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts_1.0.bb
@@ -16,6 +16,8 @@ SYSTEMD_SERVICE_${PN} = "run-agl-postinsts.service"
SYSTEMD_SERVICE_AFTER ?= "dbus.service cynara.service"
+SYSTEMD_SERVICE_BEFORE ?= "systemd-user-sessions.service"
+
do_configure() {
:
}
@@ -39,6 +41,7 @@ do_install() {
${D}${systemd_unitdir}/system/run-agl-postinsts.service
sed -i -e 's:#SYSTEMD_SERVICE_AFTER#:${SYSTEMD_SERVICE_AFTER}:g' \
+ -e 's:#SYSTEMD_SERVICE_BEFORE#:${SYSTEMD_SERVICE_BEFORE}:g' \
${D}${systemd_unitdir}/system/run-agl-postinsts.service
}