summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-05-31 20:28:00 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-02 00:57:45 +0000
commit72e4d6c436bf563d4858ba56361e8de305581075 (patch)
tree2a187da9648a624d7895adfdd8eb8e540ac7d46f /meta-agl
parent0ea9f9fd830ec1e9a5bc776cac7a9cab7c452a24 (diff)
tcf-agent: kill with USR2 in systemd stop
tcf-agent ignores SIGTERM, so upstream uses USR2 instead. This issue was noticed by Jan Kiszka and Brian Avery around the same time: https://patchwork.openembedded.org/patch/139546/ https://patchwork.openembedded.org/patch/139560/ However, these patches fixed only the init scripts, not the systemd service file. This patch fixes the systemd file. Change-Id: Id59fab32ae78213efe98a646dce2eec0881720f6 Signed-off-by: Martin Kelly <mkelly@xevo.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9597 Reviewed-by: José Bollo <jobol@nonadev.net> Reviewed-by: Changhyeok Bae <changhyeok.bae@gmail.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-devtools/tcf-agent/tcf-agent/tcf-agent.service12
-rw-r--r--meta-agl/recipes-devtools/tcf-agent/tcf-agent_git.bbappend3
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-agl/recipes-devtools/tcf-agent/tcf-agent/tcf-agent.service b/meta-agl/recipes-devtools/tcf-agent/tcf-agent/tcf-agent.service
new file mode 100644
index 000000000..a486ac7ba
--- /dev/null
+++ b/meta-agl/recipes-devtools/tcf-agent/tcf-agent/tcf-agent.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Target Communication Framework agent
+After=network.target
+
+[Service]
+Type=forking
+ExecStart=@SBINDIR@/tcf-agent -d -L- -l0
+KillSignal=USR2
+SuccessExitStatus=USR2
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl/recipes-devtools/tcf-agent/tcf-agent_git.bbappend b/meta-agl/recipes-devtools/tcf-agent/tcf-agent_git.bbappend
new file mode 100644
index 000000000..6f444b32f
--- /dev/null
+++ b/meta-agl/recipes-devtools/tcf-agent/tcf-agent_git.bbappend
@@ -0,0 +1,3 @@
+# This is a backport of:
+# https://patchwork.openembedded.org/patch/140355/
+FILESEXTRAPATHS_prepend := "${THISDIR}/tcf-agent:"