summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-09-20 00:02:38 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-26 11:54:07 +0000
commit88f8497b7a4cc5db87bfab6d88e49acaff2cd470 (patch)
treebd0cda6d1668c49b418bf91ed1f10f4002dc5e4b /meta-agl
parent6a5e107b07e576ee455f28b30f023eda00bb13ff (diff)
recipes-connectvity: bluez5: resolve CVE-2017-1000250
Add patchset that fixes BlueBorne CVE in the Bluez library for older versions of Bluez 5. Backport: https://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/meta/recipes-connectivity/bluez5?id=9376bbc8a04ced3c0973805e6cb2529b6db03076 Bug-AGL: SPEC-902 Change-Id: I33fa9a1cc0867cec9586bc0f3ed9b2bb092ff6de Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10987 ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch34
-rw-r--r--meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch b/meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch
new file mode 100644
index 000000000..9fac961bc
--- /dev/null
+++ b/meta-agl/recipes-connectivity/bluez5/bluez5/cve-2017-1000250.patch
@@ -0,0 +1,34 @@
+All versions of the SDP server in BlueZ 5.46 and earlier are vulnerable to an
+information disclosure vulnerability which allows remote attackers to obtain
+sensitive information from the bluetoothd process memory. This vulnerability
+lies in the processing of SDP search attribute requests.
+
+CVE: CVE-2017-1000250
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 9e009647b14e810e06626dde7f1bb9ea3c375d09 Mon Sep 17 00:00:00 2001
+From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
+Date: Wed, 13 Sep 2017 10:01:40 +0300
+Subject: sdp: Fix Out-of-bounds heap read in service_search_attr_req function
+
+Check if there is enough data to continue otherwise return an error.
+---
+ src/sdpd-request.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sdpd-request.c b/src/sdpd-request.c
+index 1eefdce..318d044 100644
+--- a/src/sdpd-request.c
++++ b/src/sdpd-request.c
+@@ -917,7 +917,7 @@ static int service_search_attr_req(sdp_req_t *req, sdp_buf_t *buf)
+ } else {
+ /* continuation State exists -> get from cache */
+ sdp_buf_t *pCache = sdp_get_cached_rsp(cstate);
+- if (pCache) {
++ if (pCache && cstate->cStateValue.maxBytesSent < pCache->data_size) {
+ uint16_t sent = MIN(max, pCache->data_size - cstate->cStateValue.maxBytesSent);
+ pResponse = pCache->data;
+ memcpy(buf->data, pResponse + cstate->cStateValue.maxBytesSent, sent);
+--
+cgit v1.1
diff --git a/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend
index ffb9d5b53..543681550 100644
--- a/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -1,5 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " file://bluetooth.conf"
+SRC_URI_append = " file://bluetooth.conf \
+ file://cve-2017-1000250.patch"
do_install_append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf