summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-08-30 21:19:07 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-18 03:45:46 +0000
commite48cb247218a9274faa78c535c95d0e0dbaa4686 (patch)
tree0c19f9090b949bebd0a77eafa54aa85433fa0df7 /meta-agl
parentefcc26fe2b1c0be45924c7434a7a95e311a34e05 (diff)
navigation: add geoclue package
Add geoclue package to the packagegroup agl-ivi-navi-lbs forward port dependency fix to recipe, and add dbus policy to allow client access. Bug-AGL: SPEC-852 Change-Id: Ib4d5bf22bdfebd162355d3d91850c7ebb6cd3154 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10769 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb1
-rw-r--r--meta-agl/recipes-navigation/geoclue/files/org.freedesktop.GeoClue2.Client.conf8
-rw-r--r--meta-agl/recipes-navigation/geoclue/geoclue_%.bbappend10
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb
index b280b587e..b7f47eecc 100644
--- a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb
@@ -10,4 +10,5 @@ PACKAGES = "\
RDEPENDS_${PN} += "\
gpsd \
+ geoclue \
"
diff --git a/meta-agl/recipes-navigation/geoclue/files/org.freedesktop.GeoClue2.Client.conf b/meta-agl/recipes-navigation/geoclue/files/org.freedesktop.GeoClue2.Client.conf
new file mode 100644
index 000000000..a7486d055
--- /dev/null
+++ b/meta-agl/recipes-navigation/geoclue/files/org.freedesktop.GeoClue2.Client.conf
@@ -0,0 +1,8 @@
+<!DOCTYPE busconfig PUBLIC
+ "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+ <policy user="root">
+ <allow receive_type="signal" receive_interface="org.freedesktop.GeoClue2.Client" />
+ </policy>
+</busconfig>
diff --git a/meta-agl/recipes-navigation/geoclue/geoclue_%.bbappend b/meta-agl/recipes-navigation/geoclue/geoclue_%.bbappend
new file mode 100644
index 000000000..1025e0e79
--- /dev/null
+++ b/meta-agl/recipes-navigation/geoclue/geoclue_%.bbappend
@@ -0,0 +1,10 @@
+DEPENDS += "gobject-introspection-native"
+inherit gobject-introspection
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = "file://org.freedesktop.GeoClue2.Client.conf"
+
+do_install_append() {
+ install -d ${D}/etc/dbus-1/system.d
+ install -m 0644 ${WORKDIR}/org.freedesktop.GeoClue2.Client.conf ${D}/etc/dbus-1/system.d/org.freedesktop.GeoClue2.Client.conf
+}