summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-09-17 00:22:00 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-17 17:49:29 +0000
commitefcc26fe2b1c0be45924c7434a7a95e311a34e05 (patch)
treeeb5f2f1651c8b3cff4ba27bb935b6e02f952f7ce /meta-agl
parent3d6217e8d41dee73fe79e9f8dd5fa1b53ff06da0 (diff)
autogen-native: backport autogen-native POSIX_SHELL fix
fix autogen-native: /bin/sh: bad interpreter: Permission denied /bin/sh: ../autoopts/tpl/texi2mdoc: /tmp/yocto-autobuilder/yocto-autobuilder/ yocto-worker/res-custom-pyro-multi-: bad interpreter: Permission denied POSIX_SHELL as shebang doesn't work when it is longer than BINPRM_BUF_SIZE which is 128 usually. So use "/bin/sh". Backport: https://bugzilla.yoctoproject.org/show_bug.cgi?id=11965 Backport: https://github.com/RobertBerger/poky/commit/92a17c9074538a38d3d11c063be624f6c62a6352 Bug-AGL: SPEC-892 Change-Id: I12d08e8a89373390b5798ab6ed8d0ff88d0c03c7 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10931 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-devtools/autogen/autogen-native_5.18.12.bbappend2
-rw-r--r--meta-agl/recipes-devtools/autogen/files/0003-autoopts-mk-tpl-config.sh-fix-shell-path.patch29
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-agl/recipes-devtools/autogen/autogen-native_5.18.12.bbappend b/meta-agl/recipes-devtools/autogen/autogen-native_5.18.12.bbappend
new file mode 100644
index 000000000..a6f697cdb
--- /dev/null
+++ b/meta-agl/recipes-devtools/autogen/autogen-native_5.18.12.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = "file://0003-autoopts-mk-tpl-config.sh-fix-shell-path.patch"
diff --git a/meta-agl/recipes-devtools/autogen/files/0003-autoopts-mk-tpl-config.sh-fix-shell-path.patch b/meta-agl/recipes-devtools/autogen/files/0003-autoopts-mk-tpl-config.sh-fix-shell-path.patch
new file mode 100644
index 000000000..db6b0cdf8
--- /dev/null
+++ b/meta-agl/recipes-devtools/autogen/files/0003-autoopts-mk-tpl-config.sh-fix-shell-path.patch
@@ -0,0 +1,29 @@
+From df4f5ccc376a630b1a587a8ca3b1f35a305867dd Mon Sep 17 00:00:00 2001
+From: Robert Berger <robert.berger@ReliableEmbeddedSystems.com>
+Date: Wed, 23 Aug 2017 07:19:03 +0000
+Subject: [PATCH] autoopts/mk-tpl-config.sh: fix shell path
+
+POSIX_SHELL as shebang doesn't work when it is longer than
+BINPRM_BUF_SIZE which is 128 usually. So use "/bin/sh".
+
+Signed-off-by: Robert Berger <robert.berger@ReliableEmbeddedSystems.com>
+---
+ autoopts/mk-tpl-config.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/autoopts/mk-tpl-config.sh b/autoopts/mk-tpl-config.sh
+index c4708a2..550870e 100755
+--- a/autoopts/mk-tpl-config.sh
++++ b/autoopts/mk-tpl-config.sh
+@@ -102,7 +102,7 @@ fix_scripts() {
+ sed 1d $f
+ ;;
+
+- */sh ) echo '#!' ${POSIX_SHELL}
++ */sh ) echo '#!/bin/sh'
+ sed 1d $f
+ ;;
+
+--
+2.7.4
+