summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/conf
diff options
context:
space:
mode:
authorGerrit Code Review <gerrit@automotivelinux.org>2017-03-28 13:52:42 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2017-03-28 13:52:42 +0000
commit2ceaa31f4137a5a9fb759338827f4b5d1d995772 (patch)
tree154a25036134c42d5ed51ab471b90b4e20d607fb /meta-app-framework/conf
parentef0b30d05bd1d04ebe5edfafd1c26d2b09bd7d6e (diff)
parent7fcf42ba21c2a00a60f32140924fefc3cc39ad28 (diff)
Merge "Merge: migrate appfw from meta-agl-extra"
Diffstat (limited to 'meta-app-framework/conf')
-rw-r--r--meta-app-framework/conf/include/agl-appfw-smack.inc16
-rw-r--r--meta-app-framework/conf/layer.conf11
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-app-framework/conf/include/agl-appfw-smack.inc b/meta-app-framework/conf/include/agl-appfw-smack.inc
new file mode 100644
index 000000000..133f6b04c
--- /dev/null
+++ b/meta-app-framework/conf/include/agl-appfw-smack.inc
@@ -0,0 +1,16 @@
+# enable security features (smack, cynara) - required by Application Framework
+OVERRIDES .= ":smack"
+DISTRO_FEATURES_append = " smack dbus-cynara xattr"
+
+# use tar-native to support SMACK extended attributes independently of host config
+IMAGE_CMD_TAR = "tar --xattrs --xattrs-include='*'"
+IMAGE_DEPENDS_tar_append = " tar-replacement-native"
+EXTRANATIVEPATH += "tar-native"
+
+# security: enable ssh server in place of dropbear to support PAM on user sessions
+IMAGE_FEATURES += "ssh-server-openssh"
+
+# enforce copy of xattrs (to be removed, see SPEC-475)
+PACKAGECONFIG_append_pn-shadow = " attr"
+PACKAGECONFIG_append_pn-shadow-native = " attr"
+
diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
new file mode 100644
index 000000000..f74ebd658
--- /dev/null
+++ b/meta-app-framework/conf/layer.conf
@@ -0,0 +1,11 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "app-framework"
+BBFILE_PATTERN_app-framework = "^${LAYERDIR}/"
+BBFILE_PRIORITY_app-framework = "7"
+