summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-config
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-23 16:00:59 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2017-03-27 15:33:39 +0200
commit1ac5c704bb4b7fd72d9e382ccf23f4d186da0f86 (patch)
treef5df879594fb92d3c02c05ed240cbcfcc0e70c39 /meta-app-framework/recipes-config
parent5875cc45a671b1a3e7671ec84ec6ebb1ab17696a (diff)
add layer meta-app-framework
meta-app-framework is a layer containing the AGL App Framework recipes 4 new layers are added for application framework: * meta-intel-iot-security/meta-security-smack * meta-intel-iot-security/meta-security-framework * meta-agl/meta-agl-security * meta-agl/meta-app-framework Configuration file changes to support AppFw: * activation of Smack and Cynara * modify the tar command to be used to support Smack extended attributes Change-Id: Idc8abdc8869787feb4b534ee45bf7b5d3dde3632 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-config')
-rw-r--r--meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb b/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
new file mode 100644
index 000000000..0f61248db
--- /dev/null
+++ b/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
@@ -0,0 +1,65 @@
+inherit allarch useradd
+
+SUMMARY = "AGL Users Seed"
+DESCRIPTION = "This is a core framework component that\
+ defines how users are managed and who are the default users."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+
+SRC_URI = ""
+
+
+RDEPENDS_${PN}_append_smack = " smack-userspace"
+DEPENDS_append_smack = " smack-userspace-native"
+
+ALLOW_EMPTY_${PN} = "1"
+
+USERADD_PACKAGES = "${PN}"
+
+USERADD_PARAM_${PN} = "\
+ -g users -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
+ -g users -d /home/agl-passenger -m -K PASS_MAX_DAYS=-1 agl-passenger \
+"
+
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ :
+}
+
+
+pkg_postinst_${PN}() {
+ #!/bin/sh -e
+
+ # avoid to run on host
+ [ x"$D" != "x" ] && exit 1
+
+ # Drops password
+ passwd -d agl-driver
+ passwd -d agl-passenger
+}
+
+pkg_postinst_${PN}_smack() {
+ #!/bin/sh -e
+
+ # avoid to run on host
+ [ x"$D" != "x" ] && exit 1
+
+ # Actions to carry out on the device go here
+ for x in /etc/skel /home/*
+ do
+ chsmack -a User::Home $x
+ done
+ passwd -d agl-driver
+ passwd -d agl-passenger
+}
+