summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-config
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-01 17:52:10 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:46:20 +0000
commit80f4d503fc5bb2564b72b72daedebf74612c30f3 (patch)
tree1100b288e5b0f57d93f32fe6ba38fdf5a021ce4a /meta-app-framework/recipes-config
parent86180838e730d7ef96256f2c1e49081072ad84b6 (diff)
add meta-app-framework to meta-agl
meta-app-framework is a layer containing the AGL App Framework recipes 4 new layers are added for application framework: * meta-intel-iot-security/meta-security-smack * meta-intel-iot-security/meta-security-framework * meta-agl/meta-agl-security * meta-agl/meta-app-framework In the templates files, the following changes were done: * activation of Smack and Cynara * modify the tar command to be used to support Smack extended attributes Change-Id: If369221ca7614fe0072f2a0f99a5051ef2af831d Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-config')
-rw-r--r--meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb b/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
new file mode 100644
index 000000000..0f61248db
--- /dev/null
+++ b/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
@@ -0,0 +1,65 @@
+inherit allarch useradd
+
+SUMMARY = "AGL Users Seed"
+DESCRIPTION = "This is a core framework component that\
+ defines how users are managed and who are the default users."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+
+SRC_URI = ""
+
+
+RDEPENDS_${PN}_append_smack = " smack-userspace"
+DEPENDS_append_smack = " smack-userspace-native"
+
+ALLOW_EMPTY_${PN} = "1"
+
+USERADD_PACKAGES = "${PN}"
+
+USERADD_PARAM_${PN} = "\
+ -g users -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
+ -g users -d /home/agl-passenger -m -K PASS_MAX_DAYS=-1 agl-passenger \
+"
+
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ :
+}
+
+
+pkg_postinst_${PN}() {
+ #!/bin/sh -e
+
+ # avoid to run on host
+ [ x"$D" != "x" ] && exit 1
+
+ # Drops password
+ passwd -d agl-driver
+ passwd -d agl-passenger
+}
+
+pkg_postinst_${PN}_smack() {
+ #!/bin/sh -e
+
+ # avoid to run on host
+ [ x"$D" != "x" ] && exit 1
+
+ # Actions to carry out on the device go here
+ for x in /etc/skel /home/*
+ do
+ chsmack -a User::Home $x
+ done
+ passwd -d agl-driver
+ passwd -d agl-passenger
+}
+