summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-config
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 07:37:25 -0400
committerScott Murray <scott.murray@konsulko.com>2024-12-19 22:39:59 -0500
commit08abedf095a36d4b3664e6424687dd7a9899d1a6 (patch)
tree37f713280296faa471ddcd0b77b60722b4b206dc /meta-app-framework/recipes-config
parent145a07781f8492b859c51a8d493909aabf4e22e9 (diff)
Update recipes for transition to UNPACKDIR
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I32e277e15e5aa1ac93dadc67199dedd148d3d0b9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-app-framework/recipes-config')
-rw-r--r--meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
index 57dda7787..c4de20b38 100644
--- a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
+++ b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
@@ -2,9 +2,12 @@ SUMMARY = "Rule for agl-driver to control agl-app@ services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+DEPENDS += "polkit"
+
SRC_URI = "file://50-agl-app.rules"
-DEPENDS += "polkit"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
inherit useradd features_check
REQUIRED_DISTRO_FEATURES = "polkit"
@@ -12,7 +15,7 @@ REQUIRED_DISTRO_FEATURES = "polkit"
do_install() {
install -m 700 -d ${D}${datadir}/polkit-1/rules.d
chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
- install -m 0644 ${WORKDIR}/50-agl-app.rules ${D}${datadir}/polkit-1/rules.d
+ install -m 0644 ${UNPACKDIR}/50-agl-app.rules ${D}${datadir}/polkit-1/rules.d
}
USERADD_PACKAGES = "${PN}"