summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-26 15:33:50 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-27 09:28:28 +0100
commitc720ba115fe659868691822170a0374aaef9aeed (patch)
treed2d31e25dd566272c7adf1d257ec09fc3b4d72a6 /meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
parent72d14f16bf3e16f977e483446dbac2c92fd0f68a (diff)
af-binder: Upgrade
Improvements: - addition of supervisor (in devel mode) - handling of mimetype - integration of systemd watchdog - refactor of code handling sessions - hooking of sessions - started: isolation of systemd event loop - started: test of the code Fixes: - exclude directories starting with dot (.) from search to avoid issues with debugging libraries - memory leaks - session leaks - segmentation fault on disconnections - robustness against time adjust Bug-AGL: SPEC-1293 Bug-AGL: SPEC-1296 Bug-AGL: SPEC-1303 Change-Id: Idb7908b8a4148a052c72aa662e1d453356d8e40d Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb')
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 1850e2bd8..91f26b894 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -4,12 +4,27 @@ DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
inherit cmake pkgconfig
-EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=ON -DINCLUDE_MONITORING=ON"
+EXTRA_OECMAKE_append_class-target = "\
+ -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
+"
+
+EXTRA_OECMAKE_append_agl-devel = " \
+ -DAGL_DEVEL=ON \
+ -DINCLUDE_MONITORING=ON \
+ -DINCLUDE_SUPERVISOR=ON -DAFS_SURPERVISION_SOCKET=/run/platform/supervisor \
+"
pkg_postinst_${PN}() {
mkdir -p "$D${libdir}/afb"
}
+do_install_append_agl-devel_class-target() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
+ ln -s ../afs-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afs-supervisor.service
+ fi
+}
+
#############################################
# setup package
#############################################
@@ -17,7 +32,7 @@ PACKAGES =+ "${PN}-tools ${PN}-devtools ${PN}-meta"
FILES_${PN} += "${datadir}"
-FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring"
+FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
ALLOW_EMPTY_${PN}-meta = "1"