summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-binder/af-binder_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-08-23 11:56:42 +0000
commitdd6fc5dcaa0a027b7651bb365d5dd0f623498f8f (patch)
tree428562251f7033e4d44c848e7258243fb9421a94 /meta-app-framework/recipes-core/af-binder/af-binder_git.bb
parent756165e01db655cdbd2788eb134fba79fea7fd90 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia3bf63b7cb1aa1d95ada373d1a3ab56def0a125d Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26564 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework/recipes-core/af-binder/af-binder_git.bb')
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_git.bb38
1 files changed, 19 insertions, 19 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_git.bb b/meta-app-framework/recipes-core/af-binder/af-binder_git.bb
index cf20e25a1..4728e47ea 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_git.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_git.bb
@@ -4,21 +4,21 @@ DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
inherit cmake pkgconfig
-EXTRA_OECMAKE_append_class-target = "\
+EXTRA_OECMAKE:append:class-target = "\
-DUNITDIR_SYSTEM=${systemd_system_unitdir} \
"
-EXTRA_OECMAKE_append_agl-devel = " \
+EXTRA_OECMAKE:append:agl-devel = " \
-DAGL_DEVEL=ON \
-DINCLUDE_MONITORING=ON \
-DINCLUDE_SUPERVISOR=ON -DAFS_SUPERVISION_SOCKET=/run/platform/supervisor \
"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
mkdir -p "$D${libdir}/afb"
}
-do_install_append_agl-devel_class-target() {
+do_install:append:agl-devel:class-target() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
ln -s ../afm-api-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-api-supervisor.service
@@ -29,19 +29,19 @@ do_install_append_agl-devel_class-target() {
# main package
#############################################
-FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
+FILES:${PN}:append:agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
-RDEPENDS_${PN}-dev += "libafbwsc-dev"
+RDEPENDS:${PN}-dev += "libafbwsc-dev"
#############################################
# intrinsic binding packages
#############################################
PACKAGES =+ "${PN}-intrinsic-bindings"
-ALLOW_EMPTY_${PN}-intrinsic-bindings = "1"
+ALLOW_EMPTY:${PN}-intrinsic-bindings = "1"
PACKAGES_DYNAMIC = "${PN}-binding-*"
-python populate_packages_prepend () {
+python populate_packages:prepend () {
afb_libdir = d.expand('${libdir}/afb')
postinst = d.getVar('binding_postinst', True)
pkgs = []
@@ -49,7 +49,7 @@ python populate_packages_prepend () {
pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
- d.setVar('RDEPENDS_' + d.getVar('PN', True) + '-intrinsic-bindings', ' '.join(pkgs))
+ d.setVar('RDEPENDS:' + d.getVar('PN', True) + '-intrinsic-bindings', ' '.join(pkgs))
}
#############################################
@@ -57,7 +57,7 @@ python populate_packages_prepend () {
#############################################
PACKAGES =+ "${PN}-tools"
-FILES_${PN}-tools = "\
+FILES:${PN}-tools = "\
${bindir}/afb-client-demo \
"
@@ -66,10 +66,10 @@ FILES_${PN}-tools = "\
#############################################
PACKAGES =+ "libafbwsc libafbwsc-dev"
-FILES_libafbwsc = "\
+FILES:libafbwsc = "\
${libdir}/libafbwsc.so.* \
"
-FILES_libafbwsc-dev = "\
+FILES:libafbwsc-dev = "\
${includedir}/afb/afb-wsj1.h \
${includedir}/afb/afb-ws-client.h \
${libdir}/libafbwsc.so \
@@ -81,7 +81,7 @@ FILES_libafbwsc-dev = "\
#############################################
PACKAGES =+ "${PN}-devtools"
-FILES_${PN}-devtools = "\
+FILES:${PN}-devtools = "\
${bindir}/afb-exprefs \
${bindir}/afb-json2c \
${bindir}/afb-genskel \
@@ -90,9 +90,9 @@ FILES_${PN}-devtools = "\
#############################################
# supervisor package
#############################################
-PACKAGES_append_agl-devel = " ${PN}-supervisor "
+PACKAGES:append:agl-devel = " ${PN}-supervisor "
-FILES_${PN}-supervisor_agl-devel = "\
+FILES:${PN}-supervisor:agl-devel = "\
${bindir}/afs-supervisor \
${systemd_system_unitdir} \
"
@@ -102,7 +102,7 @@ FILES_${PN}-supervisor_agl-devel = "\
#############################################
PACKAGES =+ "${PN}-samples"
-FILES_${PN}-samples = "\
+FILES:${PN}-samples = "\
${datadir}/af-binder \
"
@@ -110,8 +110,8 @@ FILES_${PN}-samples = "\
# meta package
#############################################
PACKAGES =+ "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
+ALLOW_EMPTY:${PN}-meta = "1"
-RDEPENDS_${PN}-meta += "${PN} ${PN}-tools libafbwsc ${PN}-intrinsic-bindings"
-RDEPENDS_${PN}-meta_append_agl-devel = " ${PN}-supervisor "
+RDEPENDS:${PN}-meta += "${PN} ${PN}-tools libafbwsc ${PN}-intrinsic-bindings"
+RDEPENDS:${PN}-meta:append:agl-devel = " ${PN}-supervisor "