summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-binder
diff options
context:
space:
mode:
authorStephane DESNEUX <stephane.desneux@iot.bzh>2016-06-24 10:15:26 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-24 11:39:58 +0000
commit641df47d096fb559d6f4f444670205e4510d6791 (patch)
tree72b8dc420e28e8d06e73f5d379d4063bd998be1a /meta-app-framework/recipes-core/af-binder
parent8bfa5542dbd7cb014401113080ef22bc3abd80a6 (diff)
Revert "add meta-app-framework to meta-agl"
This reverts commit 80f4d503fc5bb2564b72b72daedebf74612c30f3. Change-Id: I94605d4c0ef80433fa6eaa05e63a9c6cf69baea4 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/af-binder')
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
deleted file mode 100644
index 4fcff66e7..000000000
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ /dev/null
@@ -1,73 +0,0 @@
-SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
-DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented plugins (sound, radio...), \
-allowing HTML5 UIs to send platform-specific requests in a secure way."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-DEPENDS = "file json-c libmicrohttpd systemd util-linux"
-DEPENDS += "alsa-lib glib-2.0 gssdp gupnp gupnp-av pulseaudio"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=1.0"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
- ${SRC_URI_files} \
- "
-
-SRCREV = "897aa6a130eab1eb716fcc13e650fb5833a7ce32"
-S = "${WORKDIR}/git"
-
-inherit cmake pkgconfig
-
-FILES_${PN} += "${datadir}"
-
-#############################################
-# setup meta package
-#############################################
-PACKAGES += "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
-
-#############################################
-# setup sample plugin packages
-#############################################
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
-
-python populate_packages_prepend () {
- afb_libdir = d.expand('${libdir}/afb')
- postinst = d.getVar('plugin_postinst', True)
- pkgs = []
- pkgs_dbg = []
-
- pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
- pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
-
- pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*)-api\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
- pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
-
- metapkg = d.getVar('PN', True) + '-meta'
- d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
-}
-
-#############################################
-# setup libafbwsc package
-#############################################
-PACKAGES =+ "libafbwsc libafbwsc-dev libafbwsc-dbg"
-
-FILES_libafbwsc = "\
- ${libdir}/libafbwsc.so.* \
-"
-FILES_libafbwsc-dev = "\
- ${includedir}/afb/afb-wsj1.h \
- ${includedir}/afb/afb-ws-client.h \
- ${bindir}/afb-client-demo \
- ${libdir}/libafbwsc.so \
- ${libdir}/pkgconfig/libafbwsc.pc \
-"
-FILES_libafbwsc-dbg = "\
- ${libdir}/.debug/libafbwsc.so.* \
- ${bindir}/.debug/afb-client-demo \
-"
-RDEPENDS_libafbwsc-dbg += "${PN}-dbg libafbwsc-dev"
-