summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-07-08 15:08:25 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2017-03-27 15:33:39 +0200
commit491d35dab07f14229b6d63477fb439fa39f2c869 (patch)
treef3c775081f1e9ba2a36e0ab7291ebc56a71bd465 /meta-app-framework/recipes-core/af-main/af-main_1.0.bb
parent7289a1e7edc0a42e0070cd425608b037ea3aaf2b (diff)
meta-app-framework: add af-main-tools and dependencies in nativesdk-packagegroup-sdk-host
This is required to install app framework sdk tools. Change-Id: Iad407420fa734c063926d1883c288af387155668 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/af-main/af-main_1.0.bb')
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb25
1 files changed, 3 insertions, 22 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index 5bcfdf9d5..75cdcc3ef 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -1,3 +1,5 @@
+require af-main_${PV}.inc
+
# NOTE: using libcap-native and setcap in install doesn't work
# NOTE: there is no SYSTEMD_USER_SERVICE_...
# NOTE: maybe setting afm_name to agl-framework is cleaner but has implications
@@ -6,28 +8,8 @@
inherit cmake pkgconfig useradd systemd
-SUMMARY = "AGL Framework Main part"
-DESCRIPTION = "\
-This is a core framework component for managing \
-applications, widgets, and components. \
-"
-
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-main"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=master"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
- ${SRC_URI_files} \
- "
-
-SRCREV = "81df68c04dc5e32d5d6d06bc20a7030afdf45f59"
-
SECTION = "base"
-S = "${WORKDIR}/git"
-
DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c security-manager libcap-native af-binder"
afm_name = "afm"
@@ -38,6 +20,7 @@ afb_binding_dir = "${libdir}/afb"
EXTRA_OECMAKE = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=0 \
+ -DUSE_SDK=0 \
-Dafm_name=${afm_name} \
-Dafm_confdir=${afm_confdir} \
-Dafm_datadir=${afm_datadir} \
@@ -91,5 +74,3 @@ PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
FILES_${PN}-tools = "${bindir}/wgtpkg-*"
FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
-BBCLASSEXTEND = "native nativesdk"
-
tring.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
<?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 17.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="100px" height="100px" viewBox="0 0 100 100" enable-background="new 0 0 100 100" xml:space="preserve">
<g>
	<g>
		<path fill="#231F20" d="M79.048,14H20.952C17.128,14,14,17.128,14,20.952v58.096C14,82.872,17.128,86,20.952,86h58.096
			C82.872,86,86,82.872,86,79.048V20.952C86,17.128,82.872,14,79.048,14z M74.41,36.852c-0.565,2.938-4.314,13.219-11.107,22.297
			c-2.97,3.836-6.442,7.604-10.897,10.206c-1.643,0.96-4.893,2.172-7.052,1.266c-1.512-0.629-2.672-1.955-3.601-3.617
			c-1.672-2.998-2.577-7.097-3.362-10.206c-0.725-2.851-1.405-5.558-2.291-8.036c-0.516-1.455-0.83-2.927-1.43-4.325
			c-0.003-0.005-0.006-0.01-0.009-0.014c0.003,0.004,0.005,0.009,0.007,0.014c-0.024-0.038-0.045-0.069-0.068-0.104
			c0.02,0.03,0.041,0.059,0.061,0.091c-0.168-0.39-0.352-0.773-0.577-1.148c-1.7-2.828-4.133-0.11-6.686-0.481
			c-0.689-0.1-1.211-0.595-1.549-1.121C25.655,41.373,26,41.062,25,40.81v-0.275c4-2.916,7.17-6.455,11.46-8.939
			c1.345-0.782,3.736-1.668,5.591-1.129c1.46,0.422,2.791,1.779,3.508,3.752c0.002,0,0.002,0,0.002,0
			c0.131,0,0.247,0.651,0.34,0.942c0.715,2.214,1.099,5.043,1.463,7.194c0.577,3.387,0.481,8.631,2.415,11.59h0.002
			c0.255,0,0.544,0.686,0.875,1.038c3.169,3.345,5.587-1.36,6.878-3.724c1.116-2.052,2.115-4.219,2.288-6.172
			c0.099-1.107,0.045-2.004-0.15-2.699c-0.553-1.973-2.255-2.446-4.921-2.355c-0.34,0.012-0.694,0.027-1.064,0.056
			c2.424-7.427,9.553-10.53,11.658-10.848c2.593-0.39,6.372-0.312,8.149,1.907c0.356,0.441,0.611,0.927,0.79,1.436
			C74.74,33.897,74.675,35.389,74.41,36.852z"/>
	</g>
</g>
</svg>