summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-main/af-main_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-08-23 11:56:42 +0000
commitdd6fc5dcaa0a027b7651bb365d5dd0f623498f8f (patch)
tree428562251f7033e4d44c848e7258243fb9421a94 /meta-app-framework/recipes-core/af-main/af-main_git.bb
parent756165e01db655cdbd2788eb134fba79fea7fd90 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia3bf63b7cb1aa1d95ada373d1a3ab56def0a125d Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26564 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework/recipes-core/af-main/af-main_git.bb')
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.bb42
1 files changed, 21 insertions, 21 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.bb b/meta-app-framework/recipes-core/af-main/af-main_git.bb
index 917eaa414..8e72e4572 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.bb
@@ -11,12 +11,12 @@ BBCLASSEXTEND = "native"
SECTION = "base"
DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manager af-binder sed m4"
-DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip json-c"
-RDEPENDS_${PN}_class-target += "af-binder-tools nss-localuser cynagoauth"
+DEPENDS:class-native = "openssl libxml2 xmlsec1 libzip json-c"
+RDEPENDS:${PN}:class-target += "af-binder-tools nss-localuser cynagoauth"
-PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native libcap-native"
+PACKAGE_WRITE_DEPS:append:with-lsm-smack = " smack-native libcap-native"
-EXTRA_OECMAKE_append_class-native = "\
+EXTRA_OECMAKE:append:class-native = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=1 \
-DUSE_SDK=1 \
@@ -26,7 +26,7 @@ EXTRA_OECMAKE_append_class-native = "\
-Dafm_datadir=${afm_datadir} \
"
-EXTRA_OECMAKE_append_class-target = "\
+EXTRA_OECMAKE:append:class-target = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=0 \
-DUSE_SDK=0 \
@@ -52,23 +52,23 @@ EXTRA_OECMAKE_append_class-target = "\
AGL_FORBID_UNSIGNED_APPS ?= "0"
#
# WORKAROUND:
-EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=1"
-EXTRA_OECMAKE_append = " ${@bb.utils.contains('AGL_FORBID_UNSIGNED_APPS','1','','-DALLOW_NO_SIGNATURE=ON', d)}"
+EXTRA_OECMAKE:append:agl-devel = " -DAGL_DEVEL=1"
+EXTRA_OECMAKE:append = " ${@bb.utils.contains('AGL_FORBID_UNSIGNED_APPS','1','','-DALLOW_NO_SIGNATURE=ON', d)}"
#
# Correct version (IMPORTANT TODO: to be restored later):
-#EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=1 -DALLOW_NO_SIGNATURE=ON"
+#EXTRA_OECMAKE:append:agl-devel = " -DAGL_DEVEL=1 -DALLOW_NO_SIGNATURE=ON"
#
# ------------------------ WARNING WARNING WARNNING ---------------------------
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --gid ${afm_name} --home-dir ${afm_datadir} ${afm_name}"
-GROUPADD_PARAM_${PN} = "--system ${afm_name}"
+USERADD_PARAM:${PN} = "--system --gid ${afm_name} --home-dir ${afm_datadir} ${afm_name}"
+GROUPADD_PARAM:${PN} = "--system ${afm_name}"
-RDEPENDS_${PN}_append_with-lsm-smack = " smack bash"
-DEPENDS_append_with-lsm-smack = " smack-native"
+RDEPENDS:${PN}:append:with-lsm-smack = " smack bash"
+DEPENDS:append:with-lsm-smack = " smack-native"
-do_install_append_class-target() {
+do_install:append:class-target() {
install -d ${D}${bindir}
install -d -m 0775 ${D}${systemd_units_root}/system
install -d -m 0775 "${D}${systemd_units_root}/system/multi-user.target.wants"
@@ -87,7 +87,7 @@ do_install_append_class-target() {
fi
}
-pkg_postinst_ontarget_${PN}() {
+pkg_postinst_ontarget:${PN}() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
chgrp ${afm_name} $D${systemd_units_root}/system
chgrp ${afm_name} $D${systemd_units_root}/system/afm-user-session@.target.wants
@@ -99,7 +99,7 @@ pkg_postinst_ontarget_${PN}() {
chown ${afm_name}:${afm_name} $D${afm_datadir}/icons
}
-pkg_postinst_ontarget_${PN}_append_with-lsm-smack() {
+pkg_postinst_ontarget:${PN}:append:with-lsm-smack() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
chsmack -a 'System::Shared' -t $D${systemd_units_root}/system
chsmack -a 'System::Shared' -t $D${systemd_units_root}/system/afm-user-session@.target.wants
@@ -110,13 +110,13 @@ pkg_postinst_ontarget_${PN}_append_with-lsm-smack() {
chsmack -a 'System::Shared' -t $D${afm_datadir}/applications
chsmack -a 'System::Shared' -t $D${afm_datadir}/icons
}
-FILES_${PN} += "${systemd_units_root}/* ${systemd_system_unitdir} ${systemd_user_unitdir}"
-FILES_${PN}_append_agl-sign-wgts = " ${datadir}/afm"
+FILES:${PN} += "${systemd_units_root}/* ${systemd_system_unitdir} ${systemd_user_unitdir}"
+FILES:${PN}:append:agl-sign-wgts = " ${datadir}/afm"
PACKAGES =+ "${PN}-binding ${PN}-binding-dbg"
-FILES_${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
-FILES_${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
+FILES:${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
+FILES:${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
-FILES_${PN}-tools = "${bindir}/wgtpkg-*"
-FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
+FILES:${PN}-tools = "${bindir}/wgtpkg-*"
+FILES:${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"