summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-main/af-main_git.bb
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-10-11 14:47:24 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-04-10 14:26:21 +0000
commitf163201918c44a3c3d5788c078981cdfd2b7618a (patch)
treefa9cde6b87d3e50ba0cc2bbeb5123920ad8ac9d0 /meta-app-framework/recipes-core/af-main/af-main_git.bb
parentc935d161eef593b2d1b768126f614623c9276299 (diff)
af-main: Sign widgets when agl-devel
This change introduce signature of widgets with sample keys and certificates of app-framework-main when the feature agl-devel is selected. It also shows how to sign widgets in yocto build environment, using WGTPKG_AUTOSIGN_X environment variables. v2: Use an own agl feature for the signing and not agl-devel This allows us to switch it on selectively. Bug-AGL: SPEC-2840 Change-Id: I8f66c25a2ae62ad2365c7cdb995049c00b7c780a Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/af-main/af-main_git.bb')
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.bb b/meta-app-framework/recipes-core/af-main/af-main_git.bb
index 66b93db5d..e5a183a31 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.bb
@@ -16,7 +16,7 @@ RDEPENDS_${PN}_class-target += "af-binder-tools nss-localuser cynagoauth"
PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native libcap-native"
-EXTRA_OECMAKE_class-native = "\
+EXTRA_OECMAKE_append_class-native = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=1 \
-DUSE_SDK=1 \
@@ -26,7 +26,7 @@ EXTRA_OECMAKE_class-native = "\
-Dafm_datadir=${afm_datadir} \
"
-EXTRA_OECMAKE = "\
+EXTRA_OECMAKE_append_class-target = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=0 \
-DUSE_SDK=0 \
@@ -114,6 +114,7 @@ pkg_postinst_ontarget_${PN}_append_with-lsm-smack() {
chsmack -a 'System::Shared' -t $D${afm_datadir}/icons
}
FILES_${PN} += "${systemd_units_root}/* ${systemd_system_unitdir} ${systemd_user_unitdir}"
+FILES_${PN}_append_agl-sign-wgts = " ${datadir}/afm"
PACKAGES =+ "${PN}-binding ${PN}-binding-dbg"
FILES_${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "