summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
diff options
context:
space:
mode:
authorGerrit Code Review <gerrit@automotivelinux.org>2017-03-28 13:52:42 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2017-03-28 13:52:42 +0000
commit2ceaa31f4137a5a9fb759338827f4b5d1d995772 (patch)
tree154a25036134c42d5ed51ab471b90b4e20d607fb /meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
parentef0b30d05bd1d04ebe5edfafd1c26d2b09bd7d6e (diff)
parent7fcf42ba21c2a00a60f32140924fefc3cc39ad28 (diff)
Merge "Merge: migrate appfw from meta-agl-extra"
Diffstat (limited to 'meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb')
-rw-r--r--meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
new file mode 100644
index 000000000..8d044345f
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_1.0.bb
@@ -0,0 +1,26 @@
+require af-main_${PV}.inc
+
+inherit nativesdk cmake pkgconfig
+
+SECTION = "base"
+
+DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip nativesdk-json-c"
+
+EXTRA_OECMAKE = "\
+ -DUSE_LIBZIP=1 \
+ -DUSE_SIMULATION=1 \
+ -DUSE_SDK=1 \
+ -Dafm_name=${afm_name} \
+ -Dafm_confdir=${afm_confdir} \
+ -Dafm_datadir=${afm_datadir} \
+"
+
+do_install_append() {
+ # remove unused .pc file we don't want to package
+ rm -rf ${D}/${libdir}
+}
+
+PACKAGES = "${PN}-tools ${PN}-tools-dbg"
+FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
+FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
+