summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
diff options
context:
space:
mode:
authorJose Bollo <jose.bollo@iot.bzh>2018-09-10 14:13:41 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2018-09-14 14:20:02 +0200
commit8a4a59f9cbab1d43f07f1ff1c2c965202e36dc08 (patch)
treecd0befc3e55bfc5bf559311811ebd1bab193b271 /meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
parentc0b3f329cdd673cccedf0fb2d0e7c83e9b7e1630 (diff)
af-main & af-binder: Set version from AGLVERSION
Change-Id: Ie1ff83f007d9d8d819829540d51e576f088c97eb Signed-off-by: Jose Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb')
-rw-r--r--meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
new file mode 100644
index 000000000..759c893c7
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
@@ -0,0 +1,27 @@
+require af-main_${PV}.inc
+
+inherit nativesdk cmake pkgconfig
+
+SECTION = "base"
+
+DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip nativesdk-json-c"
+
+EXTRA_OECMAKE = "\
+ -DUSE_LIBZIP=1 \
+ -DUSE_SIMULATION=1 \
+ -DUSE_SDK=1 \
+ -DAGLVERSION=${AGLVERSION} \
+ -Dafm_name=${afm_name} \
+ -Dafm_confdir=${afm_confdir} \
+ -Dafm_datadir=${afm_datadir} \
+"
+
+do_install_append() {
+ # remove unused .pc file we don't want to package
+ rm -rf ${D}/${libdir}
+}
+
+PACKAGES = "${PN}-tools ${PN}-tools-dbg"
+FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
+FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
+