summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/af-main
diff options
context:
space:
mode:
authorStephane DESNEUX <stephane.desneux@iot.bzh>2016-06-24 10:15:26 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-24 11:39:58 +0000
commit641df47d096fb559d6f4f444670205e4510d6791 (patch)
tree72b8dc420e28e8d06e73f5d379d4063bd998be1a /meta-app-framework/recipes-core/af-main
parent8bfa5542dbd7cb014401113080ef22bc3abd80a6 (diff)
Revert "add meta-app-framework to meta-agl"
This reverts commit 80f4d503fc5bb2564b72b72daedebf74612c30f3. Change-Id: I94605d4c0ef80433fa6eaa05e63a9c6cf69baea4 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/af-main')
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main/Hack-to-allow-the-debugging.patch29
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb95
2 files changed, 0 insertions, 124 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main/Hack-to-allow-the-debugging.patch b/meta-app-framework/recipes-core/af-main/af-main/Hack-to-allow-the-debugging.patch
deleted file mode 100644
index 44e8bce1e..000000000
--- a/meta-app-framework/recipes-core/af-main/af-main/Hack-to-allow-the-debugging.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From a4fbfb88f1b7c4f4287d9279767220fae80d26da Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jos=C3=A9=20Bollo?= <jose.bollo@iot.bzh>
-Date: Thu, 21 Jan 2016 15:07:29 +0100
-Subject: [PATCH] Hack to allow the debugging
-
-This is a temporarily fix to continue debugging
-afm-main. This should be removed later.
-
-Change-Id: I2f10f0cb1fce2ee30bd0754ad2e7bc8e2f6513aa
----
- conf/afm-user-daemon.conf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/conf/afm-user-daemon.conf b/conf/afm-user-daemon.conf
-index 801c7ae..98a3152 100644
---- a/conf/afm-user-daemon.conf
-+++ b/conf/afm-user-daemon.conf
-@@ -25,7 +25,7 @@
- </policy>
-
- <policy context="default">
-- <deny own="org.AGL.afm.user"/>
-+ <allow own="org.AGL.afm.user"/>
- <allow send_destination="org.AGL.afm.system"/>
- </policy>
-
---
-2.1.4
-
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
deleted file mode 100644
index a29b071ac..000000000
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ /dev/null
@@ -1,95 +0,0 @@
-# NOTE: using libcap-native and setcap in install doesn't work
-# NOTE: there is no SYSTEMD_USER_SERVICE_...
-# NOTE: maybe setting afm_name to agl-framework is cleaner but has implications
-# NOTE: there is a hack of security for using groups and dbus (to be checked)
-# NOTE: using ZIP programs creates directories with mode 777 (very bad)
-
-inherit cmake pkgconfig useradd systemd
-
-SUMMARY = "AGL Framework Main part"
-DESCRIPTION = "\
-This is a core framework component for managing \
-applications, widgets, and components. \
-"
-
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-main"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=1.0"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
- ${SRC_URI_files} \
- "
-
-SRCREV = "d0fdae3af6998efdce4c6ba0c5d650898c9c5b27"
-
-SECTION = "base"
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c security-manager libcap-native af-binder"
-
-afm_name = "afm"
-afm_confdir = "${sysconfdir}/${afm_name}"
-afm_datadir = "${datadir}/${afm_name}"
-afb_plugin_dir = "${libdir}/afb"
-
-EXTRA_OECMAKE = "\
- -DUSE_LIBZIP=1 \
- -DUSE_SIMULATION=0 \
- -Dafm_name=${afm_name} \
- -Dafm_confdir=${afm_confdir} \
- -Dafm_datadir=${afm_datadir} \
- -DUNITDIR_USER=${systemd_user_unitdir} \
- -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
-"
-
-USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "-g ${afm_name} -d ${afm_datadir} -r ${afm_name}"
-GROUPADD_PARAM_${PN} = "-r ${afm_name}"
-
-SYSTEMD_SERVICE_${PN} = "afm-system-daemon.service"
-SYSTEMD_AUTO_ENABLE = "enable"
-
-FILES_${PN} += "\
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
-"
-
-RDEPENDS_${PN}_append_smack = " smack-userspace"
-DEPENDS_append_smack = " smack-userspace-native"
-
-# short hack here
-SRC_URI += " file://Hack-to-allow-the-debugging.patch"
-
-do_install_append() {
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- mkdir -p ${D}${sysconfdir}/systemd/user/default.target.wants
- ln -sf ${systemd_user_unitdir}/afm-user-daemon.service ${D}${sysconfdir}/systemd/user/default.target.wants
- fi
-}
-
-pkg_postinst_${PN}() {
- mkdir -p $D${afm_datadir}/applications $D${afm_datadir}/icons
- setcap cap_mac_override,cap_dac_override=ie $D${bindir}/afm-system-daemon
- setcap cap_mac_override,cap_mac_admin,cap_setgid=ie $D${bindir}/afm-user-daemon
-}
-
-pkg_postinst_${PN}_smack() {
- mkdir -p $D${afm_datadir}/applications $D${afm_datadir}/icons
- chown ${afm_name}:${afm_name} $D${afm_datadir} $D${afm_datadir}/applications $D${afm_datadir}/icons
- chsmack -a 'System::Shared' -t $D${afm_datadir} $D${afm_datadir}/applications $D${afm_datadir}/icons
- setcap cap_mac_override,cap_dac_override=ie $D${bindir}/afm-system-daemon
- setcap cap_mac_override,cap_mac_admin,cap_setgid=ie $D${bindir}/afm-user-daemon
-}
-
-PACKAGES =+ "${PN}-afbplugin ${PN}-afbplugin-dbg"
-FILES_${PN}-afbplugin = " ${afb_plugin_dir}/afm-main-plugin.so "
-FILES_${PN}-afbplugin-dbg = " ${afb_plugin_dir}/.debug/afm-main-plugin.so "
-
-PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
-FILES_${PN}-tools = "${bindir}/wgtpkg-*"
-FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
-
-BBCLASSEXTEND = "native nativesdk"
-