summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-01 17:52:10 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:46:20 +0000
commit80f4d503fc5bb2564b72b72daedebf74612c30f3 (patch)
tree1100b288e5b0f57d93f32fe6ba38fdf5a021ce4a /meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
parent86180838e730d7ef96256f2c1e49081072ad84b6 (diff)
add meta-app-framework to meta-agl
meta-app-framework is a layer containing the AGL App Framework recipes 4 new layers are added for application framework: * meta-intel-iot-security/meta-security-smack * meta-intel-iot-security/meta-security-framework * meta-agl/meta-agl-security * meta-agl/meta-app-framework In the templates files, the following changes were done: * activation of Smack and Cynara * modify the tar command to be used to support Smack extended attributes Change-Id: If369221ca7614fe0072f2a0f99a5051ef2af831d Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb')
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
new file mode 100644
index 000000000..c5b4b5366
--- /dev/null
+++ b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL Application Framework core packages"
+DESCRIPTION = "The set of packages required by the AGL Application Framework"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-app-framework \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ af-binder \
+ af-main \
+ web-runtime \
+ "