summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-12-14 14:08:16 +0100
committerStephane Desneux <stephane.desneux@iot.bzh>2017-03-27 15:33:39 +0200
commited0ec649f38a3044aaf3d36222be0391872cf2f5 (patch)
tree18ffecc1c35f5a1c2f84c44675da16177218e783 /meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
parentf947f34b2acab8fb55007c5bf5ddc677338e7c12 (diff)
Move all writable data used by security-manager and appfw to /var
The purpose of these changes is to make OSTree and AppFw update domains compatible with each other. Some intergation code is also needed to deploy initial data to writable area (see SPEC-359 in Jira). Bug-AGL: SPEC-359 Change-Id: Iccba1e9916c569167df2922ad5e2d90cc33f06fe Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com> Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend')
-rw-r--r--meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
index d3a110de5..b4b5e01c4 100644
--- a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
+++ b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
@@ -1,4 +1,16 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/security-manager:"
-SRC_URI += " file://0001-Adapt-rules-to-AGL.patch "
+SRC_URI += " file://0001-Adapt-rules-to-AGL.patch \
+ file://init-security-manager-db.service \
+ file://init-security-manager-db.sh"
+SYSTEMD_SERVICE_${PN} = "init-security-manager-db.service"
+
+FILES_${PN}_append = "${bindir}/init-security-manager-db.sh"
+
+do_install_append () {
+ install -p -D ${WORKDIR}/init-security-manager-db.sh ${D}${bindir}/init-security-manager-db.sh
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -p -D ${WORKDIR}/init-security-manager-db.service ${D}${systemd_unitdir}/system/init-security-manager-db.service
+ fi
+}