summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-11-26 15:21:18 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-03 16:44:27 +0000
commita13d8ad3225f316fc7d7edaf2805b6cf2e3b5dd1 (patch)
tree81211b592eaa332473f3dee50ae756b91335bb87 /meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
parent2fa5dae62868c63781568eeb5435ed3296c2ddc2 (diff)
security-manager: Improve integration
This fixes some issues encountered by the current integration of the security-manager: - its recipes is spread in too much directories (see SPEC-2092) - its initialization should be checked (see SPEC-2091) - the location of the database has to be changed (see SPEC-1717 that provided a workaround) All in one, I decided to create that ticket that summarize the work that can be quickly achieved to answer all this issues that are tightly coupled. Bug-AGL: SPEC-2972 Bug-AGL: SPEC-2092 Bug-AGL: SPEC-2091 Bug-AGL: SPEC-1717 Change-Id: I7af941c25cfa1624d76c2e8f512f6535918912f0 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend')
-rw-r--r--meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend24
1 files changed, 3 insertions, 21 deletions
diff --git a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
index 61c933a7e..3306d4c72 100644
--- a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
+++ b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
@@ -1,25 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/security-manager:"
-PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native"
-
-SRC_URI += " file://0001-Adapt-rules-to-AGL.patch \
- file://init-security-manager-db.service \
- file://init-security-manager-db.sh \
- file://0001-Fix-gcc6-build.patch \
- file://0001-Fix-Cmake-conf-for-gcc6-build.patch \
- file://0001-gcc-7-requires-include-functional-for-std-function.patch \
-"
-
-FILES_${PN}_append = "${bindir}/init-security-manager-db.sh \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/init-security-manager-db.service', '', d)} \
+EXTRA_OECMAKE =+ " -DGLOBALUSER=afm"
+SRC_URI += " \
+ file://0001-Adapt-rules-to-AGL.patch \
"
-do_install_append () {
- install -p -D ${WORKDIR}/init-security-manager-db.sh ${D}${bindir}/init-security-manager-db.sh
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- mkdir -p ${D}${systemd_unitdir}/system
- mkdir -p ${D}${sysconfdir}/systemd/system/default.target.wants
- install -m 644 -p -D ${WORKDIR}/init-security-manager-db.service ${D}${systemd_unitdir}/system/init-security-manager-db.service
- ln -sf ${systemd_unitdir}/system/init-security-manager-db.service ${D}${sysconfdir}/systemd/system/default.target.wants
- fi
-}