aboutsummaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-01-02 18:48:57 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2018-01-03 08:26:01 +0000
commit5f1f26130127423d678a2170c378b5da46e366f3 (patch)
treea1cf4323893a1585a326042e234400464ed9af59 /meta-app-framework/recipes-core
parentc3ac1033c4f193e8423883b17d768a13b241bb68 (diff)
Disable window decoration and ensure fullscreen
Change-Id: I2c9aad08d58b0da1fb6f362b95472f4a653fd9a3 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-core')
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml1
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb4
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml
index afe8a77d0..852567a49 100644
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml
+++ b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml
@@ -6,6 +6,7 @@ ApplicationWindow {
width: 1024
height: 768
visible: true
+ flags: Qt.WindowFullScreen | Qt.FramelessWindowHint
WebEngineView {
url: Qt.application.arguments[1]
anchors.fill: parent
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
index 8cbe08a76..75077b696 100644
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
+++ b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
@@ -7,8 +7,8 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
SRC_URI = "\
- file://web-runtime;md5sum=6114c0bdd20290912a423fa01beb50f0 \
- file://web-runtime.qml;md5sum=5d6a379e9b7e5654319e5ba638824a58 \
+ file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
+ file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
"