aboutsummaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:46:21 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-31 18:16:00 +0200
commitb43165328658087277b667152fdbc04fe07cba08 (patch)
treed1540adb65af28e41e9ebdfdbfe8b08470cb6887 /meta-app-framework/recipes-core
parentc40ee88f6aa0b379787a9ea3c853a806892e0dd1 (diff)
3rd part of the layer/profile rework [1/2]
This is the last larger commit in this series and deals with the graphical part. We introduce the graphical profiles: - meta-agl-profile-graphical -- meta-agl-profile-graphical-html5 -- meta-agl-profile-graphical-qt5 Notable changes: - weston-ini-conf moved to the meta-agl-bsp layer. Most BSPs have bbappends, so we need to have the recipes present (but unused) even in the console images. - new image: agl-image-boot = terminal-only + network + package-manaager. Ready for using package-feeds - new image/sdk: agl-image-minimal-crosssdk - agl-service-mediaplayer has a dependency on weston, thus it cannot be in the 'core'. Moved it to profile-graphical. - The wayland-ivi-extension moved to the agl-demo-platform. - The app-framework layer included and pulled 'web-runtime' as dependency. This broke console-only images. This has been moved to be in meta-agl-demo only for now. - added and massaged the agl-features. - found and added a useful script 'oe-depends-dot' that helps to work with the dot files (produced with bitbake -g) Todo: - we'll need another pass through the packagegroups. The dependencies for the layers/profiles are now sorted-out but we might have to add/shuffle a few packages. For further details, see meta-agl/docs/profiles.md. v2: fix meta-agl/meta-security/conf/layer.conf - the immediate expansion previously used in there caused some recipes not being added to BBFILES. v3: fix packagegroup renaming (packagegroup-agl-devel -> packagegroup-agl-core-devel) v4: fix missing packagegroup inclusion (tnx Jose, Scott, Stephane) v5: fix missing packagegroup inclusion v6: explicitely put profile-graphical-qt5 on-top of profile-graphical v7: re-add 'procps' when agl-devel feature is on Bug-AGL: SPEC-145 Change-Id: I24cdcd1118932758d0c55d333338238f2a770877 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework/recipes-core')
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb1
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-core-security.bbappend8
-rw-r--r--meta-app-framework/recipes-core/packagegroups/packagegroup-agl-image-minimal.bbappend3
-rwxr-xr-xmeta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime2
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml13
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml14
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb42
7 files changed, 0 insertions, 83 deletions
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
index 56f89c598..0201c0e4f 100644
--- a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
+++ b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-app-framework.bb
@@ -15,5 +15,4 @@ RDEPENDS_${PN} += "\
libafbwsc \
af-main \
systemd-agl-sync \
- ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
"
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-core-security.bbappend b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-core-security.bbappend
deleted file mode 100644
index a8d04ab6d..000000000
--- a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-core-security.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
-RDEPENDS_${PN} += "\
- xmlsec1 \
- cynara \
- security-manager \
- security-manager-policy \
- agl-users \
- "
-
diff --git a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-image-minimal.bbappend b/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-image-minimal.bbappend
deleted file mode 100644
index ad09e5ddf..000000000
--- a/meta-app-framework/recipes-core/packagegroups/packagegroup-agl-image-minimal.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-RDEPENDS_${PN} += "\
- packagegroup-agl-app-framework \
- "
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
deleted file mode 100755
index 80685eb81..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec /usr/bin/qt5/qmlscene "$1" /usr/bin/web-runtime.qml
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml
deleted file mode 100644
index d18b672cd..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml
+++ /dev/null
@@ -1,13 +0,0 @@
-import QtQuick 2.1
-import QtQuick.Controls 1.1
-import QtWebKit 3.0
-
-ApplicationWindow {
- width: 1024
- height: 768
- visible: true
- WebView {
- url: Qt.application.arguments[1]
- anchors.fill: parent
- }
-}
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml
deleted file mode 100644
index 852567a49..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml
+++ /dev/null
@@ -1,14 +0,0 @@
-import QtQuick 2.1
-import QtQuick.Controls 1.1
-import QtWebEngine 1.1
-
-ApplicationWindow {
- width: 1024
- height: 768
- visible: true
- flags: Qt.WindowFullScreen | Qt.FramelessWindowHint
- WebEngineView {
- url: Qt.application.arguments[1]
- anchors.fill: parent
- }
-}
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
deleted file mode 100644
index 75077b696..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-inherit allarch
-
-SUMMARY = "Provides the 'web-runtime' command"
-DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI = "\
- file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
- file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
- file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
-"
-
-RDEPENDS_${PN} = "\
- qtdeclarative-tools \
- qtwayland-qmlplugins \
- qtquickcontrols-qmlplugins \
-"
-
-PROVIDES += "virtual/webruntime"
-# add also RPROVIDES to satisfy the packagegroup
-RPROVIDES_${PN} += "virtual/webruntime"
-
-do_configure() {
- :
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
- install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
- install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
-}
-
-do_install_append_rcar-gen2() {
- # workaround for porter board: force the use of libEGL provided by mesa at runtime
- # otherwise, the proprietary libEGL is used and a problem then occurs due to a missing EGL function
- sed -i 's|^\(exec /usr/bin/qt5/qmlscene\)|LD_PRELOAD=/usr/lib/libEGL.so \1|g' ${D}${bindir}/web-runtime
-}
-
-