summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-08-23 11:56:42 +0000
commitdd6fc5dcaa0a027b7651bb365d5dd0f623498f8f (patch)
tree428562251f7033e4d44c848e7258243fb9421a94 /meta-app-framework/recipes-core
parent756165e01db655cdbd2788eb134fba79fea7fd90 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia3bf63b7cb1aa1d95ada373d1a3ab56def0a125d Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26564 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework/recipes-core')
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder-devtools-native_git.bb2
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_git.bb38
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_git.inc4
-rw-r--r--meta-app-framework/recipes-core/af-binder/nativesdk-af-binder-devtools_git.bb2
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.bb42
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.inc4
-rw-r--r--meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb9
-rw-r--r--meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb2
-rw-r--r--meta-app-framework/recipes-core/base-files/base-files_appfw.inc18
-rw-r--r--meta-app-framework/recipes-core/coreutils/coreutils_appfw.inc8
-rw-r--r--meta-app-framework/recipes-core/dbus-cynagora/dbus_appfw.inc8
-rw-r--r--meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb8
-rw-r--r--meta-app-framework/recipes-core/shadow/shadow_appfw.inc2
-rw-r--r--meta-app-framework/recipes-core/smack-system-setup/smack-system-setup_1.bb6
-rw-r--r--meta-app-framework/recipes-core/systemd/systemd_appfw.inc6
-rw-r--r--meta-app-framework/recipes-core/util-linux/util-linux_appfw.inc2
16 files changed, 80 insertions, 81 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder-devtools-native_git.bb b/meta-app-framework/recipes-core/af-binder/af-binder-devtools-native_git.bb
index 70dafb38c..1331fb886 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder-devtools-native_git.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder-devtools-native_git.bb
@@ -4,5 +4,5 @@ DEPENDS = "json-c-native"
inherit cmake pkgconfig native
-EXTRA_OECMAKE_append = " -DONLY_DEVTOOLS=TRUE"
+EXTRA_OECMAKE:append = " -DONLY_DEVTOOLS=TRUE"
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_git.bb b/meta-app-framework/recipes-core/af-binder/af-binder_git.bb
index cf20e25a1..4728e47ea 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_git.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_git.bb
@@ -4,21 +4,21 @@ DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
inherit cmake pkgconfig
-EXTRA_OECMAKE_append_class-target = "\
+EXTRA_OECMAKE:append:class-target = "\
-DUNITDIR_SYSTEM=${systemd_system_unitdir} \
"
-EXTRA_OECMAKE_append_agl-devel = " \
+EXTRA_OECMAKE:append:agl-devel = " \
-DAGL_DEVEL=ON \
-DINCLUDE_MONITORING=ON \
-DINCLUDE_SUPERVISOR=ON -DAFS_SUPERVISION_SOCKET=/run/platform/supervisor \
"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
mkdir -p "$D${libdir}/afb"
}
-do_install_append_agl-devel_class-target() {
+do_install:append:agl-devel:class-target() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
ln -s ../afm-api-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-api-supervisor.service
@@ -29,19 +29,19 @@ do_install_append_agl-devel_class-target() {
# main package
#############################################
-FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
+FILES:${PN}:append:agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
-RDEPENDS_${PN}-dev += "libafbwsc-dev"
+RDEPENDS:${PN}-dev += "libafbwsc-dev"
#############################################
# intrinsic binding packages
#############################################
PACKAGES =+ "${PN}-intrinsic-bindings"
-ALLOW_EMPTY_${PN}-intrinsic-bindings = "1"
+ALLOW_EMPTY:${PN}-intrinsic-bindings = "1"
PACKAGES_DYNAMIC = "${PN}-binding-*"
-python populate_packages_prepend () {
+python populate_packages:prepend () {
afb_libdir = d.expand('${libdir}/afb')
postinst = d.getVar('binding_postinst', True)
pkgs = []
@@ -49,7 +49,7 @@ python populate_packages_prepend () {
pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
- d.setVar('RDEPENDS_' + d.getVar('PN', True) + '-intrinsic-bindings', ' '.join(pkgs))
+ d.setVar('RDEPENDS:' + d.getVar('PN', True) + '-intrinsic-bindings', ' '.join(pkgs))
}
#############################################
@@ -57,7 +57,7 @@ python populate_packages_prepend () {
#############################################
PACKAGES =+ "${PN}-tools"
-FILES_${PN}-tools = "\
+FILES:${PN}-tools = "\
${bindir}/afb-client-demo \
"
@@ -66,10 +66,10 @@ FILES_${PN}-tools = "\
#############################################
PACKAGES =+ "libafbwsc libafbwsc-dev"
-FILES_libafbwsc = "\
+FILES:libafbwsc = "\
${libdir}/libafbwsc.so.* \
"
-FILES_libafbwsc-dev = "\
+FILES:libafbwsc-dev = "\
${includedir}/afb/afb-wsj1.h \
${includedir}/afb/afb-ws-client.h \
${libdir}/libafbwsc.so \
@@ -81,7 +81,7 @@ FILES_libafbwsc-dev = "\
#############################################
PACKAGES =+ "${PN}-devtools"
-FILES_${PN}-devtools = "\
+FILES:${PN}-devtools = "\
${bindir}/afb-exprefs \
${bindir}/afb-json2c \
${bindir}/afb-genskel \
@@ -90,9 +90,9 @@ FILES_${PN}-devtools = "\
#############################################
# supervisor package
#############################################
-PACKAGES_append_agl-devel = " ${PN}-supervisor "
+PACKAGES:append:agl-devel = " ${PN}-supervisor "
-FILES_${PN}-supervisor_agl-devel = "\
+FILES:${PN}-supervisor:agl-devel = "\
${bindir}/afs-supervisor \
${systemd_system_unitdir} \
"
@@ -102,7 +102,7 @@ FILES_${PN}-supervisor_agl-devel = "\
#############################################
PACKAGES =+ "${PN}-samples"
-FILES_${PN}-samples = "\
+FILES:${PN}-samples = "\
${datadir}/af-binder \
"
@@ -110,8 +110,8 @@ FILES_${PN}-samples = "\
# meta package
#############################################
PACKAGES =+ "${PN}-meta"
-ALLOW_EMPTY_${PN}-meta = "1"
+ALLOW_EMPTY:${PN}-meta = "1"
-RDEPENDS_${PN}-meta += "${PN} ${PN}-tools libafbwsc ${PN}-intrinsic-bindings"
-RDEPENDS_${PN}-meta_append_agl-devel = " ${PN}-supervisor "
+RDEPENDS:${PN}-meta += "${PN} ${PN}-tools libafbwsc ${PN}-intrinsic-bindings"
+RDEPENDS:${PN}-meta:append:agl-devel = " ${PN}-supervisor "
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_git.inc b/meta-app-framework/recipes-core/af-binder/af-binder_git.inc
index d887461fd..50f60f7c7 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_git.inc
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_git.inc
@@ -14,9 +14,9 @@ PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
-CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+CFLAGS:append:agl-devel = " -DAGL_DEVEL"
-EXTRA_OECMAKE_append = "\
+EXTRA_OECMAKE:append = "\
-DAGLVERSION=${AGLVERSION} \
"
diff --git a/meta-app-framework/recipes-core/af-binder/nativesdk-af-binder-devtools_git.bb b/meta-app-framework/recipes-core/af-binder/nativesdk-af-binder-devtools_git.bb
index 3223dd05d..334d073c2 100644
--- a/meta-app-framework/recipes-core/af-binder/nativesdk-af-binder-devtools_git.bb
+++ b/meta-app-framework/recipes-core/af-binder/nativesdk-af-binder-devtools_git.bb
@@ -4,5 +4,5 @@ DEPENDS = "nativesdk-json-c"
inherit cmake pkgconfig nativesdk
-EXTRA_OECMAKE_append = " -DONLY_DEVTOOLS=TRUE"
+EXTRA_OECMAKE:append = " -DONLY_DEVTOOLS=TRUE"
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.bb b/meta-app-framework/recipes-core/af-main/af-main_git.bb
index 917eaa414..8e72e4572 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.bb
@@ -11,12 +11,12 @@ BBCLASSEXTEND = "native"
SECTION = "base"
DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manager af-binder sed m4"
-DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip json-c"
-RDEPENDS_${PN}_class-target += "af-binder-tools nss-localuser cynagoauth"
+DEPENDS:class-native = "openssl libxml2 xmlsec1 libzip json-c"
+RDEPENDS:${PN}:class-target += "af-binder-tools nss-localuser cynagoauth"
-PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native libcap-native"
+PACKAGE_WRITE_DEPS:append:with-lsm-smack = " smack-native libcap-native"
-EXTRA_OECMAKE_append_class-native = "\
+EXTRA_OECMAKE:append:class-native = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=1 \
-DUSE_SDK=1 \
@@ -26,7 +26,7 @@ EXTRA_OECMAKE_append_class-native = "\
-Dafm_datadir=${afm_datadir} \
"
-EXTRA_OECMAKE_append_class-target = "\
+EXTRA_OECMAKE:append:class-target = "\
-DUSE_LIBZIP=1 \
-DUSE_SIMULATION=0 \
-DUSE_SDK=0 \
@@ -52,23 +52,23 @@ EXTRA_OECMAKE_append_class-target = "\
AGL_FORBID_UNSIGNED_APPS ?= "0"
#
# WORKAROUND:
-EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=1"
-EXTRA_OECMAKE_append = " ${@bb.utils.contains('AGL_FORBID_UNSIGNED_APPS','1','','-DALLOW_NO_SIGNATURE=ON', d)}"
+EXTRA_OECMAKE:append:agl-devel = " -DAGL_DEVEL=1"
+EXTRA_OECMAKE:append = " ${@bb.utils.contains('AGL_FORBID_UNSIGNED_APPS','1','','-DALLOW_NO_SIGNATURE=ON', d)}"
#
# Correct version (IMPORTANT TODO: to be restored later):
-#EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=1 -DALLOW_NO_SIGNATURE=ON"
+#EXTRA_OECMAKE:append:agl-devel = " -DAGL_DEVEL=1 -DALLOW_NO_SIGNATURE=ON"
#
# ------------------------ WARNING WARNING WARNNING ---------------------------
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --gid ${afm_name} --home-dir ${afm_datadir} ${afm_name}"
-GROUPADD_PARAM_${PN} = "--system ${afm_name}"
+USERADD_PARAM:${PN} = "--system --gid ${afm_name} --home-dir ${afm_datadir} ${afm_name}"
+GROUPADD_PARAM:${PN} = "--system ${afm_name}"
-RDEPENDS_${PN}_append_with-lsm-smack = " smack bash"
-DEPENDS_append_with-lsm-smack = " smack-native"
+RDEPENDS:${PN}:append:with-lsm-smack = " smack bash"
+DEPENDS:append:with-lsm-smack = " smack-native"
-do_install_append_class-target() {
+do_install:append:class-target() {
install -d ${D}${bindir}
install -d -m 0775 ${D}${systemd_units_root}/system
install -d -m 0775 "${D}${systemd_units_root}/system/multi-user.target.wants"
@@ -87,7 +87,7 @@ do_install_append_class-target() {
fi
}
-pkg_postinst_ontarget_${PN}() {
+pkg_postinst_ontarget:${PN}() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
chgrp ${afm_name} $D${systemd_units_root}/system
chgrp ${afm_name} $D${systemd_units_root}/system/afm-user-session@.target.wants
@@ -99,7 +99,7 @@ pkg_postinst_ontarget_${PN}() {
chown ${afm_name}:${afm_name} $D${afm_datadir}/icons
}
-pkg_postinst_ontarget_${PN}_append_with-lsm-smack() {
+pkg_postinst_ontarget:${PN}:append:with-lsm-smack() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
chsmack -a 'System::Shared' -t $D${systemd_units_root}/system
chsmack -a 'System::Shared' -t $D${systemd_units_root}/system/afm-user-session@.target.wants
@@ -110,13 +110,13 @@ pkg_postinst_ontarget_${PN}_append_with-lsm-smack() {
chsmack -a 'System::Shared' -t $D${afm_datadir}/applications
chsmack -a 'System::Shared' -t $D${afm_datadir}/icons
}
-FILES_${PN} += "${systemd_units_root}/* ${systemd_system_unitdir} ${systemd_user_unitdir}"
-FILES_${PN}_append_agl-sign-wgts = " ${datadir}/afm"
+FILES:${PN} += "${systemd_units_root}/* ${systemd_system_unitdir} ${systemd_user_unitdir}"
+FILES:${PN}:append:agl-sign-wgts = " ${datadir}/afm"
PACKAGES =+ "${PN}-binding ${PN}-binding-dbg"
-FILES_${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
-FILES_${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
+FILES:${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
+FILES:${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
-FILES_${PN}-tools = "${bindir}/wgtpkg-*"
-FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
+FILES:${PN}-tools = "${bindir}/wgtpkg-*"
+FILES:${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.inc b/meta-app-framework/recipes-core/af-main/af-main_git.inc
index 5ac76a796..11d563a34 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.inc
@@ -21,10 +21,10 @@ afm_datadir = "/var/local/lib/${afm_name}"
afb_binding_dir = "${libdir}/afb"
systemd_units_root = "/var/local/lib/systemd"
-CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+CFLAGS:append:agl-devel = " -DAGL_DEVEL"
# only install sample keys in agl-devel mode
# for production you need to deploy real keys
-EXTRA_OECMAKE_append_agl-sign-wgts = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '-DINSTALL_SAMPLE_KEYS=ON', '-DINSTALL_SAMPLE_KEYS=OFF', d)}"
+EXTRA_OECMAKE:append:agl-sign-wgts = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '-DINSTALL_SAMPLE_KEYS=ON', '-DINSTALL_SAMPLE_KEYS=OFF', d)}"
diff --git a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
index 88ab4ae68..4564831a8 100644
--- a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
+++ b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
@@ -16,13 +16,12 @@ EXTRA_OECMAKE = "\
-Dafm_datadir=${afm_datadir} \
"
-do_install_append() {
+do_install:append() {
# remove unused .pc file we don't want to package
rm -rf ${D}/${libdir}
}
PACKAGES = "${PN}-tools ${PN}-tools-dbg"
-FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
-FILES_${PN}-tools_append_agl-sign-wgts = " ${datadir}/afm"
-FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
-
+FILES:${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
+FILES:${PN}-tools:append:agl-sign-wgts = " ${datadir}/afm"
+FILES:${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
diff --git a/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb b/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb
index eb473cd14..52c7a6534 100644
--- a/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb
+++ b/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb
@@ -13,4 +13,4 @@ do_install() {
install -m 0644 ${S}/udev-shared.conf $d
}
-FILES_${PN} = "${systemd_system_unitdir}"
+FILES:${PN} = "${systemd_system_unitdir}"
diff --git a/meta-app-framework/recipes-core/base-files/base-files_appfw.inc b/meta-app-framework/recipes-core/base-files/base-files_appfw.inc
index 848a39ff4..4c8301314 100644
--- a/meta-app-framework/recipes-core/base-files/base-files_appfw.inc
+++ b/meta-app-framework/recipes-core/base-files/base-files_appfw.inc
@@ -1,7 +1,7 @@
-RDEPENDS_${PN}_append_with-lsm-smack = " smack"
-PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native"
+RDEPENDS:${PN}:append:with-lsm-smack = " smack"
+PACKAGE_WRITE_DEPS:append:with-lsm-smack = " smack-native"
-do_install_append() {
+do_install:append() {
install -m 0700 -d ${D}/${sysconfdir}/skel
chmod -R 0700 ${D}/${sysconfdir}/skel
install -m 0700 -d ${D}/${sysconfdir}/skel/app-data
@@ -15,7 +15,7 @@ do_install_append() {
ln -s ../var/local ${D}/usr/local
}
-do_install_append_with-lsm-smack () {
+do_install:append:with-lsm-smack () {
install -d ${D}/${sysconfdir}/smack/accesses.d
cat > ${D}/${sysconfdir}/smack/accesses.d/default-access-domains-no-user <<EOF
System User::App-Shared rwxat
@@ -24,7 +24,7 @@ EOF
chmod 0644 ${D}/${sysconfdir}/smack/accesses.d/default-access-domains-no-user
}
-pkg_postinst_${PN}_append_with-lsm-smack() {
+pkg_postinst:${PN}:append:with-lsm-smack() {
chsmack -r -a 'User::Home' -t -D $D/${sysconfdir}/skel
chsmack -a 'User::App-Shared' -D $D/${sysconfdir}/skel/app-data
cp -rTf --preserve=all $D/${sysconfdir}/skel $D/${ROOT_HOME}
@@ -35,7 +35,7 @@ pkg_postinst_${PN}_append_with-lsm-smack() {
# Install default Smack rules, copied from a running Tizen IVI 3.0.
# Corresponds to manifest file from default-access-domains in Tizen:
# https://review.tizen.org/git?p=platform/core/security/default-ac-domains.git;a=blob;f=packaging/default-ac-domains.manifest
-do_install_append_with-lsm-smack () {
+do_install:append:with-lsm-smack () {
install -d ${D}/${sysconfdir}/smack/accesses.d
cat >${D}/${sysconfdir}/smack/accesses.d/default-access-domains <<EOF
System _ -----l
@@ -74,9 +74,9 @@ EOF
# via postinst. This is much easier to use with bitbake, too:
# - no need to maintain a patched rpm
# - works for directories which are not packaged by default when empty
-RDEPENDS_${PN}_append_with-lsm-smack = " smack"
-DEPENDS_append_with-lsm-smack = " smack-native"
-pkg_postinst_${PN}_with-lsm-smack() {
+RDEPENDS:${PN}:append:with-lsm-smack = " smack"
+DEPENDS:append:with-lsm-smack = " smack-native"
+pkg_postinst:${PN}:with-lsm-smack() {
#!/bin/sh -e
# https://review.tizen.org/gerrit/gitweb?p=platform/upstream/filesystem.git;a=blob;f=packaging/filesystem.manifest:
diff --git a/meta-app-framework/recipes-core/coreutils/coreutils_appfw.inc b/meta-app-framework/recipes-core/coreutils/coreutils_appfw.inc
index 1b9b722ec..234487531 100644
--- a/meta-app-framework/recipes-core/coreutils/coreutils_appfw.inc
+++ b/meta-app-framework/recipes-core/coreutils/coreutils_appfw.inc
@@ -1,7 +1,7 @@
# Smack patches are included in coreutils v8.22, we just need to enable them.
# The default is not deterministic (enabled if libsmack found), so disable
# explicitly otherwise.
-EXTRA_OECONF_SMACK_class-target = "--disable-libsmack"
-EXTRA_OECONF_SMACK_with-lsm-smack_class-target = "--enable-libsmack"
-EXTRA_OECONF_append_class-target = " ${EXTRA_OECONF_SMACK}"
-DEPENDS_append_with-lsm-smack_class-target = " smack"
+EXTRA_OECONF_SMACK:class-target = "--disable-libsmack"
+EXTRA_OECONF_SMACK:with-lsm-smack:class-target = "--enable-libsmack"
+EXTRA_OECONF:append:class-target = " ${EXTRA_OECONF_SMACK}"
+DEPENDS:append:with-lsm-smack:class-target = " smack"
diff --git a/meta-app-framework/recipes-core/dbus-cynagora/dbus_appfw.inc b/meta-app-framework/recipes-core/dbus-cynagora/dbus_appfw.inc
index 177a117b8..4efeef7b8 100644
--- a/meta-app-framework/recipes-core/dbus-cynagora/dbus_appfw.inc
+++ b/meta-app-framework/recipes-core/dbus-cynagora/dbus_appfw.inc
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/dbus-cynagora:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/dbus-cynagora:"
-SRC_URI_append_class-target = "\
+SRC_URI:append:class-target = "\
file://0001-Integration-of-Cynara-asynchronous-security-checks.patch \
file://0002-Disable-message-dispatching-when-send-rule-result-is.patch \
file://0003-Handle-unavailability-of-policy-results-for-broadcas.patch \
@@ -10,6 +10,6 @@ SRC_URI_append_class-target = "\
file://0007-Switch-from-cynara-to-cynagora.patch \
"
-DEPENDS_append_class-target = " cynagora smack"
-EXTRA_OECONF_append_class-target = " ${@bb.utils.contains('DISTRO_FEATURES','smack','--enable-cynagora --disable-selinux','',d)}"
+DEPENDS:append:class-target = " cynagora smack"
+EXTRA_OECONF:append:class-target = " ${@bb.utils.contains('DISTRO_FEATURES','smack','--enable-cynagora --disable-selinux','',d)}"
diff --git a/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb b/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb
index 45861f7cc..93d2a2034 100644
--- a/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb
+++ b/meta-app-framework/recipes-core/nss-localuser/nss-localuser_0.1.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/nss-localuser;protocol=ht
SRCREV = "66803c6fdb609ed83a78b9194ecb23e9c1b773e7"
PV = "${AGL_BRANCH}+git${SRCPV}"
-RDEPENDS_${PN} = "base-files"
+RDEPENDS:${PN} = "base-files"
S = "${WORKDIR}/git"
@@ -25,15 +25,15 @@ do_install() {
make nssdir=${D}${libdir} install
}
-pkg_postinst_ontarget_${PN} () {
+pkg_postinst_ontarget:${PN} () {
sed -e '/^hosts:/s/\<localuser\>\s*//' \
-e 's/\(^hosts:\s\s*\)\(.*\)/\1localuser \2/' \
-i $D${sysconfdir}/nsswitch.conf
}
-pkg_prerm_${PN} () {
+pkg_prerm:${PN} () {
sed -e '/^hosts:/s/\<localuser\>\s*//' \
-i $D${sysconfdir}/nsswitch.conf
}
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
diff --git a/meta-app-framework/recipes-core/shadow/shadow_appfw.inc b/meta-app-framework/recipes-core/shadow/shadow_appfw.inc
index 472ffef2c..d41c996e9 100644
--- a/meta-app-framework/recipes-core/shadow/shadow_appfw.inc
+++ b/meta-app-framework/recipes-core/shadow/shadow_appfw.inc
@@ -1,3 +1,3 @@
-do_install_append() {
+do_install:append() {
sed -i '/^UMASK/s:^.*$:UMASK 077:' ${D}${sysconfdir}/login.defs
}
diff --git a/meta-app-framework/recipes-core/smack-system-setup/smack-system-setup_1.bb b/meta-app-framework/recipes-core/smack-system-setup/smack-system-setup_1.bb
index 49b12ad3f..b74f462b4 100644
--- a/meta-app-framework/recipes-core/smack-system-setup/smack-system-setup_1.bb
+++ b/meta-app-framework/recipes-core/smack-system-setup/smack-system-setup_1.bb
@@ -9,9 +9,9 @@ SRC_URI = "\
file://tmp.mount.conf \
"
-RDEPENDS_${PN}_append_with-lsm-smack = " smack"
+RDEPENDS:${PN}:append:with-lsm-smack = " smack"
-do_install_append_with-lsm-smack() {
+do_install:append:with-lsm-smack() {
# tuning systemd units
install -Dm0644 ${WORKDIR}/systemd-tmpfiles-setup.service.conf \
${D}${systemd_unitdir}/system/systemd-tmpfiles-setup.service.d/smack.conf
@@ -25,4 +25,4 @@ do_install_append_with-lsm-smack() {
${D}${sysconfdir}/udev/rules.d/55-udev-smack-default.rules
}
-FILES_${PN} += "${systemd_unitdir}"
+FILES:${PN} += "${systemd_unitdir}"
diff --git a/meta-app-framework/recipes-core/systemd/systemd_appfw.inc b/meta-app-framework/recipes-core/systemd/systemd_appfw.inc
index a5e1ae840..8aa72c570 100644
--- a/meta-app-framework/recipes-core/systemd/systemd_appfw.inc
+++ b/meta-app-framework/recipes-core/systemd/systemd_appfw.inc
@@ -1,7 +1,7 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/systemd:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/systemd:"
# Ensures systemd runs with label "System"
-EXTRA_OEMESON_append_with-lsm-smack = " -Dsmack-run-label=System"
+EXTRA_OEMESON:append:with-lsm-smack = " -Dsmack-run-label=System"
##################################################################################
# Maintaining trivial, non-upstreamable configuration changes as patches
@@ -34,7 +34,7 @@ patch_systemd() {
# This comes with the recipe systemd_230/234 of poky (meta/recipes-core/systemd)
# It should be removed when poky changes.
##################################################################################
-do_install_prepend() {
+do_install:prepend() {
mv ${WORKDIR}/touchscreen.rules ${WORKDIR}/55-touchscreen.rules || true
}
diff --git a/meta-app-framework/recipes-core/util-linux/util-linux_appfw.inc b/meta-app-framework/recipes-core/util-linux/util-linux_appfw.inc
index 05286f80d..7399aa44d 100644
--- a/meta-app-framework/recipes-core/util-linux/util-linux_appfw.inc
+++ b/meta-app-framework/recipes-core/util-linux/util-linux_appfw.inc
@@ -4,5 +4,5 @@
# booting with "security=none" when userspace otherwise is
# compiled to use Smack.
-PACKAGECONFIG_append_with-lsm-smack_class-target = " smack"
+PACKAGECONFIG:append:with-lsm-smack:class-target = " smack"
PACKAGECONFIG[smack] = "--with-smack, --without-smack"