summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
diff options
context:
space:
mode:
authorStephane DESNEUX <stephane.desneux@iot.bzh>2016-06-24 10:15:26 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-24 11:39:58 +0000
commit641df47d096fb559d6f4f444670205e4510d6791 (patch)
tree72b8dc420e28e8d06e73f5d379d4063bd998be1a /meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
parent8bfa5542dbd7cb014401113080ef22bc3abd80a6 (diff)
Revert "add meta-app-framework to meta-agl"
This reverts commit 80f4d503fc5bb2564b72b72daedebf74612c30f3. Change-Id: I94605d4c0ef80433fa6eaa05e63a9c6cf69baea4 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb')
-rw-r--r--meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb b/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
deleted file mode 100644
index b624b6bab..000000000
--- a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "Sample client for AFM to install/start/stop/remove applications"
-DESCRIPTION = "afm-client is a sample AngularJS/HTML5 application using \
-Application Framework Manager to install, start, stop, or remove \
-applications provided as .wgt widget packages."
-HOMEPAGE = "http://www.iot.bzh"
-
-inherit systemd
-
-LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
-
-#DEPENDS = "nodejs-native"
-RDEPENDS_${PN} = "af-main af-binder af-main-afbplugin af-binder-plugin-demopost af-binder-plugin-authlogin"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=1.0"
-SRC_URI_files = "file://afm-client \
- file://afm-client.service \
- "
-SRC_URI = "${SRC_URI_git} \
- ${SRC_URI_files} \
- "
-SRCREV = "9e9b459fa27d7a359a060024c9639b99b45813d5"
-S = "${WORKDIR}/git/afm-client"
-
-do_install () {
- mkdir -p ${D}/${datadir}/agl/afm-client
- cp -ra ${S}/dist.prod/* ${D}/${datadir}/agl/afm-client/
-
- mkdir -p ${D}/${bindir}
- install -m 0755 ${WORKDIR}/afm-client ${D}/${bindir}/afm-client
-
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_user_unitdir}
- install -d ${D}${sysconfdir}/systemd/user/default.target.wants
- install -m 0644 ${WORKDIR}/afm-client.service ${D}/${systemd_user_unitdir}/afm-client.service
- ln -sf ${systemd_user_unitdir}/afm-client.service ${D}${sysconfdir}/systemd/user/default.target.wants
- fi
-}
-
-FILES_${PN} += "${datadir} ${systemd_user_unitdir}"