aboutsummaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-security/cynara/cynara_git.bbappend
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-12-17 15:31:05 +0000
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-13 11:01:59 +0100
commit86c97d2b6c78d0fbbb21f9b4aeef75335e1912b5 (patch)
tree7f09116425df4f7bcbd88501ad25e282f48ed854 /meta-app-framework/recipes-security/cynara/cynara_git.bbappend
parentc482595a42cb47f322667ec949ad283cf40d715b (diff)
cynara: Fix build error that causes gcc v7.0
- gcc v7 requires include <functional> for std::function. - gcc v7 recognize implicit-fallthrough. Bug-AGL: SPEC-1181 Change-Id: I40b35ef54d3a1e567330102e9e7cbe6882728b95 Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
Diffstat (limited to 'meta-app-framework/recipes-security/cynara/cynara_git.bbappend')
-rw-r--r--meta-app-framework/recipes-security/cynara/cynara_git.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-security/cynara/cynara_git.bbappend b/meta-app-framework/recipes-security/cynara/cynara_git.bbappend
index 9a61e7044..4c38da1cc 100644
--- a/meta-app-framework/recipes-security/cynara/cynara_git.bbappend
+++ b/meta-app-framework/recipes-security/cynara/cynara_git.bbappend
@@ -1,3 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+SRC_URI_append = " file://0001-gcc-7-requires-include-functional-for-std-function.patch"
+
+CXXFLAGS_append = " -Wimplicit-fallthrough=0"
+
pkg_postinst_${PN} () {
# Fail on error.
set -e