summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/scripts/run-yocto-check-layer-enabled-flags.sh
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:07:53 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-28 13:40:57 +0200
commite98bbd0216a00716c351f39e17511367e77e0866 (patch)
tree0d08b14456a5b99cf92e6830f2a4f4d6f111e230 /meta-app-framework/scripts/run-yocto-check-layer-enabled-flags.sh
parent1b0d65113b277610135b5599c8810ca7a4e3df4c (diff)
Prepare master for new framework integrationsandbox/jsmoeller/rmappfw
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - meta-agl-core: remove Smack kernel patches - meta-app-framework - meta-pipewire/dynamic-layers/meta-app-framework/ Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: Icdaeadfb5d2193f3a4c535168c88da6073423e67
Diffstat (limited to 'meta-app-framework/scripts/run-yocto-check-layer-enabled-flags.sh')
-rwxr-xr-xmeta-app-framework/scripts/run-yocto-check-layer-enabled-flags.sh51
1 files changed, 0 insertions, 51 deletions
diff --git a/meta-app-framework/scripts/run-yocto-check-layer-enabled-flags.sh b/meta-app-framework/scripts/run-yocto-check-layer-enabled-flags.sh
deleted file mode 100755
index 762a79e83..000000000
--- a/meta-app-framework/scripts/run-yocto-check-layer-enabled-flags.sh
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/bash
-set -x
-SCRIPTPATH="$( cd $(dirname $0) >/dev/null 2>&1 ; pwd -P )"
-echo $SCRIPTPATH
-AGLROOT="$SCRIPTPATH/../../.."
-POKYDIR="$AGLROOT/external/poky"
-TMPROOT="/tmp"
-
-rm -rf ${TMPROOT}/testbuild-ycl || true
-mkdir -p ${TMPROOT}/testbuild-ycl
-cd ${TMPROOT}/testbuild-ycl
-
-source $POKYDIR/oe-init-build-env .
-
-cat << EOF >> conf/local.conf
-# just define defaults
-AGL_FEATURES ?= ""
-AGL_EXTRA_IMAGE_FSTYPES ?= ""
-
-# important settings imported from poky-agl.conf
-# we do not import
-DISTRO_FEATURES:append = " systemd smack"
-DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
-VIRTUAL-RUNTIME_init_manager = "systemd"
-
-# skip unnecessary in yocto-check-layer - aka FIXME upstream
-BBMASK += "meta-security/recipes-mac/smack/smack-test_1.0.bb"
-BBMASK += "packagegroup-core-security-ptest.bb"
-
-# missing in upstream recipes ... aka FIXME upstream
-BBCLASSEXTEND:pn-libzip = "native nativesdk"
-BBCLASSEXTEND:pn-xmlsec1 = "native nativesdk"
-
-DISTRO_FEATURES:append = " appfw smack "
-
-EOF
-
-
-yocto-check-layer \
- --dependency $AGLROOT/external/meta-openembedded/meta-oe \
- $AGLROOT/external/meta-security \
- $AGLROOT/external/meta-openembedded/meta-python \
- $AGLROOT/external/meta-openembedded/meta-networking \
- $AGLROOT/external/meta-openembedded/meta-perl \
- $AGLROOT/external/meta-qt5/ \
- -- \
- $AGLROOT/meta-agl/meta-app-framework/
-
-[ $? = 0 ] && rm -rf ${TMPROOT}/testbuild-ycl
-
-