summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/scripts/run-yocto-check-layer.sh
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:07:53 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-04 14:24:17 +0000
commitd468ce3b3d602f7c8a88d67126a32900b76fd433 (patch)
treeef7543ddb14168c2b3d8725b95399d2ecaba9f2a /meta-app-framework/scripts/run-yocto-check-layer.sh
parentabc4742a714cfc60a868c0912432a6f59fd41b77 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - meta-agl-core: remove Smack kernel patches - meta-app-framework - meta-pipewire/dynamic-layers/meta-app-framework/ v2: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: Icdaeadfb5d2193f3a4c535168c88da6073423e67 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26752
Diffstat (limited to 'meta-app-framework/scripts/run-yocto-check-layer.sh')
-rwxr-xr-xmeta-app-framework/scripts/run-yocto-check-layer.sh49
1 files changed, 0 insertions, 49 deletions
diff --git a/meta-app-framework/scripts/run-yocto-check-layer.sh b/meta-app-framework/scripts/run-yocto-check-layer.sh
deleted file mode 100755
index c324d64f9..000000000
--- a/meta-app-framework/scripts/run-yocto-check-layer.sh
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/bash
-set -x
-SCRIPTPATH="$( cd $(dirname $0) >/dev/null 2>&1 ; pwd -P )"
-echo $SCRIPTPATH
-AGLROOT="$SCRIPTPATH/../../.."
-POKYDIR="$AGLROOT/external/poky"
-TMPROOT="/tmp"
-
-rm -rf ${TMPROOT}/testbuild-ycl || true
-mkdir -p ${TMPROOT}/testbuild-ycl
-cd ${TMPROOT}/testbuild-ycl
-
-source $POKYDIR/oe-init-build-env .
-
-cat << EOF >> conf/local.conf
-# just define defaults
-AGL_FEATURES ?= ""
-AGL_EXTRA_IMAGE_FSTYPES ?= ""
-
-# important settings imported from poky-agl.conf
-# we do not import
-DISTRO_FEATURES:append = " systemd smack"
-DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
-VIRTUAL-RUNTIME_init_manager = "systemd"
-
-# skip unnecessary in yocto-check-layer - aka FIXME upstream
-BBMASK += "meta-security/recipes-mac/smack/smack-test_1.0.bb"
-BBMASK += "packagegroup-core-security-ptest.bb"
-
-# missing in upstream recipes ... aka FIXME upstream
-BBCLASSEXTEND:pn-libzip = "native nativesdk"
-BBCLASSEXTEND:pn-xmlsec1 = "native nativesdk"
-
-EOF
-
-
-yocto-check-layer \
- --dependency $AGLROOT/external/meta-openembedded/meta-oe \
- $AGLROOT/external/meta-security \
- $AGLROOT/external/meta-openembedded/meta-python \
- $AGLROOT/external/meta-openembedded/meta-networking \
- $AGLROOT/external/meta-openembedded/meta-perl \
- $AGLROOT/external/meta-qt5/ \
- -- \
- $AGLROOT/meta-agl/meta-app-framework/
-
-[ $? = 0 ] && rm -rf ${TMPROOT}/testbuild-ycl
-
-