summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-08-10 13:08:16 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-08-21 23:15:03 +0000
commitad929d2b623ed3e98ad525e6b1c886004129e220 (patch)
treea6d2f208fa1c02bdb2390918f38a908b5a7b5fa5 /meta-app-framework
parent89264bcd51b77d305ef4f3d3170a1d8b74b5adf1 (diff)
af-binder: bug fix and feature improvements
fixes: - webkit connection on websockets (SPEC-821) - over allocation of sessions - send error reply for unreplied requests - unprefix event name - infinite loop when events overrun counter - better handling of NULL improvements: - added trace facility of monitor builtin API - dump of stack on SIGABRT - facility afb_req_subcall_req - reduced verbosity - debugging enhanced: allow break after wait and call to 'personality' - documentation Bug-AGL: SPEC-821 Change-Id: I90f16aca97613616e7f2fb4bb85c052ae16c0cde Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10609 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Romain Forlot <romain.forlot@iot.bzh> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index c0e15820e..05e0a7a1c 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -15,7 +15,7 @@ SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
"
-SRCREV = "c9ec9b1a76ce90048974476b1a5aa1be89b58536"
+SRCREV = "8406a51db98b563a4562f26de8338efc0478aff2"
PV = "master+git${SRCPV}"
S = "${WORKDIR}/git"
.Constant */ .highlight .nd { color: #555555 } /* Name.Decorator */ .highlight .ne { color: #bb0066; font-weight: bold } /* Name.Exception */ .highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */ .highlight .nl { color: #336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
/*
 * Copyright (C) 2016 "IoT.bzh"
 * Author Fulup Ar Foll <fulup@iot.bzh>
 *
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *   http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
 */

#define _GNU_SOURCE
#include <stdio.h>
#include <string.h>
#include <unistd.h>
#include <errno.h>
#include <netdb.h>
#include <fcntl.h>
#include <math.h>
#include <sys/time.h>
#include <sys/types.h>

#include "Alsa-ApiHat.h"

/*
 * array of the verbs exported to afb-daemon
 */
static const struct afb_verb_v2 api_verbs[] = {
  /* VERB'S NAME          FUNCTION TO CALL  */
  { .verb= "ping"   ,     .callback= pingtest },
  { .verb= "getinfo",     .callback= alsaGetInfo},
  { .verb= "getctl",      .callback= alsaGetCtls},
  { .verb= "setctl",      .callback= alsaSetCtls},
  { .verb= "subscribe",   .callback= alsaEvtSubcribe},
  { .verb= "getcardid",   .callback= alsaGetCardId},
  { .verb= "halregister", .callback= alsaRegisterHal},
  { .verb= "hallist",     .callback= alsaActiveHal},
  { .verb= "ucmquery",    .callback= alsaUseCaseQuery},
  { .verb= "ucmset",      .callback= alsaUseCaseSet},
  { .verb= "ucmget",      .callback= alsaUseCaseGet},
  { .verb= "ucmreset",    .callback= alsaUseCaseReset},
  { .verb= "ucmclose",    .callback= alsaUseCaseClose},
  { .verb= "addcustomctl",.callback= alsaAddCustomCtls},
  { .verb= NULL } /* marker for end of the array */
};

/*
 * description of the binding for afb-daemon
 */
const struct afb_binding_v2 afbBindingV2 = {
    .api     = "alsacore",
    .verbs   = api_verbs,
};