summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-05 09:33:04 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-07 10:59:36 +0000
commit1ac22f0594fe3dffc8989af3eac311dd5e785644 (patch)
tree1b7804f92c7e9934dd0d83a9becb4c2de09a6879 /meta-app-framework
parent983756ae4fad13a6d8f57b8a1c484d12265460f9 (diff)
Framework: Leverage agl-devel and set PV
It is time for the framework to include development specific features intended to be used when developing applications. This commit prepares such use. See: AGL-Bug: SPEC-594 It also changes the version PV to point the correct AGL distribution/branch and git commit. Change-Id: Ib6abbc3d83ee3eecb79b574f988b430221c45b33 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10085 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb4
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc3
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 2c9a7840c..0c9a78d3a 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -16,10 +16,14 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "305d98f7b6db1a3207cc877bd2cda819e3b90656"
+PV = "master+git${SRCPV}"
+
S = "${WORKDIR}/git"
inherit cmake pkgconfig
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
pkg_postinst_${PN}() {
mkdir -p "$D${libdir}/afb"
}
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index f7d3bc8e1..1fd33adf4 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -15,6 +15,7 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "5cea66506dff09e8bdebbd623115ea103e87aba6"
+PV = "master+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -24,3 +25,5 @@ afm_datadir = "/var/local/lib/${afm_name}"
afb_binding_dir = "${libdir}/afb"
systemd_units_root = "/usr/local/lib/systemd"
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+