summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-05 15:23:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-07 10:59:41 +0000
commit226471f5831753c412d05071628f14cdec6cbc5c (patch)
tree034e1441d6fd5c52082514b2bf95963ad501c5a3 /meta-app-framework
parent1ac22f0594fe3dffc8989af3eac311dd5e785644 (diff)
af-main: make sockets.target accessible by group
Bug-AGL: SPEC-726 Change-Id: I8cb62fb6353e3985d1f7c9efc141bc35f4fa6d4b Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10087 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index b71a4cba3..33d380d05 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -84,7 +84,7 @@ do_install_append_porter() {
pkg_postinst_${PN}() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
for SYS in "system" "user";do
- for DEST in "default.target.wants" ".";do
+ for DEST in "sockets.target.wants" "default.target.wants" ".";do
chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
done
done
@@ -98,7 +98,7 @@ pkg_postinst_${PN}() {
pkg_postinst_${PN}_smack() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
for SYS in "system" "user";do
- for DEST in "default.target.wants" ".";do
+ for DEST in "sockets.target.wants" "default.target.wants" ".";do
chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
chsmack -a 'System::Shared' -t $D${systemd_units_root}/${SYS}/${DEST};
done