summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-07-12 13:32:23 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-17 09:16:00 +0000
commite069eadff896a3984d6e700bbbf5788a23d318f7 (patch)
tree0c9bf92a8dd1616ca71e1d57d50736132dde55dd /meta-app-framework
parentbfc447d468f749d9161996f917ba3567ae063de4 (diff)
systemd-udev: ensure convention for naming udev rules
The udev rules files installed in /etc/udev/rules.d should follow systemd naming convention. This patch ensures it by renaming known wrong files before to install it. This patch is temporary. This is a solution to the Bug-AGL SPEC-539. It renames the file udev-smack-default.rules as the file 55-smack-default.rules before installation in do_install. This comes from https://github.com/01org/meta-intel-iot-security.git (meta-security-smack/recipes-core/systemd/) It should be removed when the security layer will be refited to meta-security See git clone http://git.yoctoproject.org/cgit/cgit.cgi/meta-security It also renames the file touchscreen.rules as the file 55-touchscreen.rules This comes with the recipe systemd_230 of poky (meta/recipes-core/systemd) It should be removed when poky changes. Bug-AGL: SPEC-539 Change-Id: Ib65e75e67ddcd814d83771777d14b5d7754bd7d4 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10169 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/systemd/systemd_%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/systemd/systemd_%.bbappend b/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 000000000..6b8057a5c
--- /dev/null
+++ b/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,20 @@
+##################################################################################
+# This patch is temporary.
+# This is a solution to the Bug-AGL SPEC-539.
+#
+# It renames the file udev-smack-default.rules
+# as the file 55-smack-default.rules before installation in do_install.
+# This comes from https://github.com/01org/meta-intel-iot-security.git
+# (meta-security-smack/recipes-core/systemd/)
+# It should be removed when the security layer will be refited to meta-security
+# See git clone http://git.yoctoproject.org/cgit/cgit.cgi/meta-security
+#
+# It also renames the file touchscreen.rules as the file 55-touchscreen.rules
+# This comes with the recipe systemd_230 of poky (meta/recipes-core/systemd)
+# It should be removed when poky changes.
+##################################################################################
+do_install_prepend() {
+ mv ${WORKDIR}/udev-smack-default.rules ${WORKDIR}/55-smack-default.rules || true
+ mv ${WORKDIR}/touchscreen.rules ${WORKDIR}/55-touchscreen.rules || true
+}
+