summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-05 12:54:08 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-05 15:12:16 +0000
commit13dc9cd09eb55bcc157da0f4ad533d3204aacad9 (patch)
treeeb2fab8ee2cceb2f8394b51e414f161f5e6f0631 /meta-app-framework
parent35d76cc9ab993be02219854d94ebecf2a694173e (diff)
Allow SRCREV handling through poky-agl.conf
This change simplifies the SRCREV handling by using - AGL_APP_REVISION and AGL_DEFAULT_REVISION in recipes. Also the AGL_BRANCH can be used to switch to release branches. Bug-AGL: SPEC-864 Change-Id: I9384c85d4f7434416d87359f88c482887ac2ead8 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11685 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb2
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb2
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc2
-rw-r--r--meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb2
-rw-r--r--meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb b/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb
index 994a46192..828022ba8 100644
--- a/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb
+++ b/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb
@@ -6,7 +6,7 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/low-level-can-service;protocol=https;branch=master"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/low-level-can-service;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "a8eaf1f71c2906140b600314dfe935fab3a06bf2"
PV = "4.0+git${SRCPV}"
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 0fc3a67e5..23dcb462d 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=${AGL_BRANCH}"
SRC_URI_files = ""
SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index a2a752400..897da2b14 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -8,7 +8,7 @@ HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-f
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
SRC_URI_files = ""
SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
diff --git a/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb b/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
index 21605d20b..f272b264f 100644
--- a/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
+++ b/meta-app-framework/recipes-example/afb-client/afb-client_1.0.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
#DEPENDS = "nodejs-native"
RDEPENDS_${PN} = "af-binder af-binder-binding-authlogin"
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=${AGL_BRANCH}"
SRC_URI_files = "file://afb-client \
"
SRC_URI = "${SRC_URI_git} \
diff --git a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb b/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
index 4cd80db64..159f69f01 100644
--- a/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
+++ b/meta-app-framework/recipes-example/afm-client/afm-client_1.0.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
#DEPENDS = "nodejs-native"
RDEPENDS_${PN} = "af-main af-binder af-main-binding af-binder-binding-demopost af-binder-binding-authlogin"
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=${AGL_BRANCH}"
SRC_URI_files = "file://afm-client \
file://afm-client.service \
"