summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-28 20:22:25 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-04-06 11:54:14 +0000
commit54c1b51066ac7e38a6eb2e05d6579e6c0aed9304 (patch)
treecff398a552a86501d95bce8d9b429b1f36babaad /meta-app-framework
parentd7489cff0cbc5937951759c3d8f30da6a47771f4 (diff)
af-main: Refactor of user session management
This changes how user session are started and handled within systemd. This evolution add a tiny program to start and handle user sessions: afm-user-session. This is the first step of a serie because, actually, due to platform restrictions, the common users if started this way will not be able to run correctly (issues with wayland/weston and with handling of CGROUP2 with Smack LSM) Also fixes memory leaks and improves build process. Bug-AGL: SPEC-545 Bug-AGL: SPEC-1016 Change-Id: Icaf7c575633fc663a3df0ffee683b22cc087bb16 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb6
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc2
2 files changed, 5 insertions, 3 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index e160486b2..68c878654 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -66,9 +66,11 @@ do_install_append_class-target() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d -m 0755 ${D}${systemd_user_unitdir}/default.target.wants
ln -s ../afm-user-daemon.service ${D}${systemd_user_unitdir}/default.target.wants/afm-user-daemon.service
- install -d -m 0755 ${D}${systemd_system_unitdir}/default.target.wants
+ ln -s ../afm-user-session.service ${D}${systemd_user_unitdir}/default.target.wants/afm-user-session.service
+ install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
install -d -m 0755 ${D}${systemd_system_unitdir}/sockets.target.wants
- ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/default.target.wants/afm-system-daemon.service
+ ln -sf ../afm-system-setup.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-setup.service
+ ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
fi
echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index 13736aee3..77963bddb 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "1bec325ee85192eba57673750b9e4a77a1a970c8"
+SRCREV = "a752e8b3033fdeb6a52349fcc7fbd618907ab474"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"