summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-12-12 12:03:43 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-14 19:32:40 +0000
commitf11a3e7653777ad4342e615f47ec4a5417a2fa96 (patch)
tree3358a5e21ef0f36a4e59dc0a189d19bb1bfd9167 /meta-app-framework
parent629062a55c41e8993761edf4a2a44400b72a6b91 (diff)
systemd: Refactor build using smack-system-setup
This changes introduces the new recipe meta-security/recipes-core/smack-system-setup/smack-system-setup_1.bb The purpose is to split the recipe of systemd in two parts: - A part specific to systemd and only systemd It actually includes Smack patches for systemd and a renaming of udev-rules. - A part more oriented on putting the system in order to run with Smack activated. At the end, it will probably save many rebuilds as systemd recipe will evolve less in relation with the setup of the system. As example, the udev rule file "55-udev-smack-default.rules" that setup udev rules specific to smack is no more brought by systemd but by smack-system-setup. Also at the same time, some cleanup and refactoring is done. Note that the ".bbappend" file for systemd is now fixed in version and is including a common file file that records the several known versions. No cleanup was made on the versioned patch for the sake of memory. The cleanup of the history is to be achieved later... Bug-AGL: SPEC-2045 Change-Id: Iacf772142a381729dfdbe98d133a3effc4d6cf68 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/systemd/systemd_%.bbappend20
-rw-r--r--meta-app-framework/recipes-platform/packagegroups/packagegroup-agl-core-security.bbappend1
2 files changed, 1 insertions, 20 deletions
diff --git a/meta-app-framework/recipes-core/systemd/systemd_%.bbappend b/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
deleted file mode 100644
index 6b8057a5c..000000000
--- a/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1,20 +0,0 @@
-##################################################################################
-# This patch is temporary.
-# This is a solution to the Bug-AGL SPEC-539.
-#
-# It renames the file udev-smack-default.rules
-# as the file 55-smack-default.rules before installation in do_install.
-# This comes from https://github.com/01org/meta-intel-iot-security.git
-# (meta-security-smack/recipes-core/systemd/)
-# It should be removed when the security layer will be refited to meta-security
-# See git clone http://git.yoctoproject.org/cgit/cgit.cgi/meta-security
-#
-# It also renames the file touchscreen.rules as the file 55-touchscreen.rules
-# This comes with the recipe systemd_230 of poky (meta/recipes-core/systemd)
-# It should be removed when poky changes.
-##################################################################################
-do_install_prepend() {
- mv ${WORKDIR}/udev-smack-default.rules ${WORKDIR}/55-smack-default.rules || true
- mv ${WORKDIR}/touchscreen.rules ${WORKDIR}/55-touchscreen.rules || true
-}
-
diff --git a/meta-app-framework/recipes-platform/packagegroups/packagegroup-agl-core-security.bbappend b/meta-app-framework/recipes-platform/packagegroups/packagegroup-agl-core-security.bbappend
index a8d04ab6d..19af9117b 100644
--- a/meta-app-framework/recipes-platform/packagegroups/packagegroup-agl-core-security.bbappend
+++ b/meta-app-framework/recipes-platform/packagegroups/packagegroup-agl-core-security.bbappend
@@ -1,4 +1,5 @@
RDEPENDS_${PN} += "\
+ smack-system-setup \
xmlsec1 \
cynara \
security-manager \